about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index a04a3b75..5b7914dc 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -235,12 +235,14 @@ check-each :: pure_all
         \$(EATMYDATA) \$(PROVE) --state=save -bvw -j\$(N)
         -@\$(check_manifest)
 
-# lightly-tested way to run tests, relies "--state=save" in check-each
-# for best performance
+# this relies "--state=save" in check-each for best performance
 check-run :: pure_all check-man
         \$(EATMYDATA) \$(PROVE) -bvw t/run.perl :: -j\$(N)
         -@\$(check_manifest)
 
+check-debris :: pure_all
+        PERL5LIB="\$\$PWD"/blib/lib \$(PROVE) -bvw xt/\$@.t
+
 check :: check-each
 
 lib/PublicInbox/UserContent.pm :: contrib/css/216dark.css