about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2023-09-18 10:15:12 +0000
committerEric Wong <e@80x24.org>2023-09-20 19:14:22 +0000
commiteb4ed924e9f8075ed134fbd590d390e208f4120f (patch)
tree54774885d0fb85e37110638726a3ddcbe345ad37 /Makefile.PL
parent2a6063fbc45803150596be0d615e8618f7126b21 (diff)
downloadpublic-inbox-eb4ed924e9f8075ed134fbd590d390e208f4120f.tar.gz
This allows us to get rid of some duplication in our Makefile
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 97e00395..9dc18b5c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -235,13 +235,16 @@ check-each :: pure_all
         \$(EATMYDATA) \$(PROVE) --state=save -bvw -j\$(N)
         -@\$(check_manifest)
 
-# this relies "--state=save" in check-each for best performance
-check-run :: pure_all check-man
-        \$(EATMYDATA) \$(PROVE) -bvw t/run.perl :: -j\$(N)
-        -@\$(check_manifest)
+# check-run relies "--state=save" in check-each for best performance
+check-run :: check-man
+
+# n.b. while `-' isn't specified as an allowed make(1posix) macro name,
+# GNU and *BSD both allow it.
+check-run_T_ARGS = -j\$(N)
 
-check-debris :: pure_all
-        PERL5LIB="\$\$PWD"/blib/lib \$(PROVE) -bvw xt/\$@.t
+check-debris check-run :: pure_all
+        \$(EATMYDATA) \$(PROVE) -bvw xt/\$@.t :: \$(\$\@_T_ARGS)
+        -@\$(check_manifest)
 
 check :: check-each