about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2023-08-26 06:13:15 +0000
committerEric Wong <e@80x24.org>2023-08-26 20:47:52 +0000
commit2312ca26023fcbe3dd9f6cd141ef19d510f32660 (patch)
treeba7a7841f36936ac662edc52799f2b3f0916f880 /Makefile.PL
parentd2ae029a15ca58831fb116d97f875870b9a246da (diff)
downloadpublic-inbox-2312ca26023fcbe3dd9f6cd141ef19d510f32660.tar.gz
I would never consider working on C++ code without at least one
one of these tools present.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 710d705d..5865a252 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -262,5 +262,14 @@ symlink-install : lib/PublicInbox.pm
 pure_all :: lib/PublicInbox.pm
 lib/PublicInbox.pm : FORCE
         VERSION=\$(VERSION) \$(PERL) -w ./version-gen.perl
+
+test-asan : pure_all
+        CXXFLAGS='-O0 -Wall -ggdb3 -fsanitize=address' \
+                prove -bvw t/xap_helper.t
+
+VG_OPT = '-v --trace-children=yes --track-fds=yes'
+VG_OPT += ' --leak-check=yes --track-origins=yes'
+test-valgrind : pure_all
+        VALGRIND="valgrind \$\$(VG_OPT)" prove -bvw t/xap_helper.t
 EOF
 }