about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2023-10-04 17:46:35 +0000
committerEric Wong <e@80x24.org>2023-10-04 22:58:22 +0000
commit14dd9df0f718f8d0815851efe52f3633ec6137b8 (patch)
tree9745ef7745c05a0888e466c656db9037b8ab27c4 /Makefile.PL
parent8fe9ff206dfc868882d8382f9b718868e2660330 (diff)
downloadpublic-inbox-14dd9df0f718f8d0815851efe52f3633ec6137b8.tar.gz
For the Makefile, we can use $(PWD) make macro from make(1posix)
as POSIX requires all environment variables be accessible as
macros, and $PWD is a standard sh(1) environment variable.

lei.sh must quiet the stderr of realpath before falling back to
readlink(1) which is available on NetBSD.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8bd39e6c..38e030f5 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -264,7 +264,7 @@ prefix = \$(HOME)
 bindir = \$(prefix)/bin
 symlink-install : lib/PublicInbox.pm
         mkdir -p \$(bindir)
-        lei=\$\$(realpath lei.sh) && cd \$(bindir) && \\
+        lei="\$(PWD)/lei.sh" && cd \$(bindir) && \\
         for x in \$(EXE_FILES); do \\
                 ln -sf "\$\$lei" \$\$(basename "\$\$x"); \\
         done