git@vger.kernel.org mailing list mirror (one of many)
 help / color / mirror / code / Atom feed
From: Junio C Hamano <gitster@pobox.com>
To: Michael Haggerty <mhagger@alum.mit.edu>
Cc: "Nguyễn Thái Ngọc Duy" <pclouds@gmail.com>,
	"Stefan Beller" <sbeller@google.com>,
	"Johannes Schindelin" <Johannes.Schindelin@gmx.de>,
	"David Turner" <novalis@novalis.org>,
	git@vger.kernel.org
Subject: Re: [PATCH 1/5] refs: store submodule ref stores in a hashmap
Date: Thu, 09 Feb 2017 12:34:04 -0800	[thread overview]
Message-ID: <xmqqh943p0hv.fsf@gitster.mtv.corp.google.com> (raw)
In-Reply-To: <a944446c4c374125082f5ad8b79e731704b66196.1486629195.git.mhagger@alum.mit.edu> (Michael Haggerty's message of "Thu, 9 Feb 2017 14:26:58 +0100")

Michael Haggerty <mhagger@alum.mit.edu> writes:

> Aside from scaling better, this means that the submodule name needn't be
> stored in the ref_store instance anymore (which will be changed in a
> moment).

Nice.  I like the latter reason very much (this is not a suggestion
to change the description).

> +struct submodule_hash_entry
> +{
> +	struct hashmap_entry ent; /* must be the first member! */
> +
> +	struct ref_store *refs;
> +
> +	/* NUL-terminated name of submodule: */
> +	char submodule[FLEX_ARRAY];
> +};
> +
> +static int submodule_hash_cmp(const void *entry, const void *entry_or_key,
> +			      const void *keydata)
> +{
> +	const struct submodule_hash_entry *e1 = entry, *e2 = entry_or_key;
> +	const char *submodule = keydata;
> +
> +	return strcmp(e1->submodule, submodule ? submodule : e2->submodule);

I would have found it more readable if it were like so:

	const char *submodule = keydata ? keydata : e2->submodule;

	return strcmp(e1->submodule, submodule);

but I suspect the difference is not that huge.

> +}
> +
> +static struct submodule_hash_entry *alloc_submodule_hash_entry(
> +		const char *submodule, struct ref_store *refs)
> +{
> +	size_t len = strlen(submodule);
> +	struct submodule_hash_entry *entry = malloc(sizeof(*entry) + len + 1);

I think this (and the later memcpy) is what FLEX_ALLOC_MEM() was
invented for.

> +	hashmap_entry_init(entry, strhash(submodule));
> +	entry->refs = refs;
> +	memcpy(entry->submodule, submodule, len + 1);
> +	return entry;
> +}
> ...
> @@ -1373,16 +1405,17 @@ void base_ref_store_init(struct ref_store *refs,
>  			die("BUG: main_ref_store initialized twice");
>  
>  		refs->submodule = "";
> -		refs->next = NULL;
>  		main_ref_store = refs;
>  	} else {
> -		if (lookup_ref_store(submodule))
> +		refs->submodule = xstrdup(submodule);
> +
> +		if (!submodule_ref_stores.tablesize)
> +			hashmap_init(&submodule_ref_stores, submodule_hash_cmp, 20);

Makes me wonder what "20" stands for.  Perhaps the caller should be
allowed to say "I do not quite care what initial size is" by passing
0 or some equally but more clealy meaningless value (which of course
would be outside the scope of this series).

  parent reply	other threads:[~2017-02-09 22:24 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-02-09 13:26 [PATCH 0/5] Store submodules in a hash, not a linked list Michael Haggerty
2017-02-09 13:26 ` [PATCH 1/5] refs: store submodule ref stores in a hashmap Michael Haggerty
2017-02-09 16:58   ` Stefan Beller
2017-02-09 17:40     ` Michael Haggerty
2017-02-09 17:43       ` Stefan Beller
2017-02-09 19:32       ` Jeff King
2017-02-09 20:34   ` Junio C Hamano [this message]
2017-02-10  4:04     ` Jeff King
2017-02-10 10:23     ` Michael Haggerty
2017-02-09 13:26 ` [PATCH 2/5] refs: push the submodule attribute down Michael Haggerty
2017-02-09 17:03   ` Stefan Beller
2017-02-09 21:07   ` Junio C Hamano
2017-02-09 13:27 ` [PATCH 3/5] register_ref_store(): new function Michael Haggerty
2017-02-09 17:20   ` Stefan Beller
2017-02-09 18:14     ` Michael Haggerty
2017-02-09 21:16   ` Junio C Hamano
2017-02-09 13:27 ` [PATCH 4/5] files_ref_store::submodule: use NULL for the main repository Michael Haggerty
2017-02-09 17:25   ` Stefan Beller
2017-02-09 21:19   ` Junio C Hamano
2017-02-09 21:36     ` Stefan Beller
2017-02-09 13:27 ` [PATCH 5/5] read_loose_refs(): read refs using resolve_ref_recursively() Michael Haggerty
2017-02-09 17:39   ` Stefan Beller
2017-02-09 19:48 ` [PATCH 0/5] Store submodules in a hash, not a linked list Junio C Hamano
2017-02-09 19:58 ` Jeff King
2017-02-09 21:23   ` Michael Haggerty
2017-02-10  0:40     ` Jeff King
2017-02-10 10:27       ` Michael Haggerty
2017-02-13  2:39       ` Duy Nguyen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: http://vger.kernel.org/majordomo-info.html

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=xmqqh943p0hv.fsf@gitster.mtv.corp.google.com \
    --to=gitster@pobox.com \
    --cc=Johannes.Schindelin@gmx.de \
    --cc=git@vger.kernel.org \
    --cc=mhagger@alum.mit.edu \
    --cc=novalis@novalis.org \
    --cc=pclouds@gmail.com \
    --cc=sbeller@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).