about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL22
1 files changed, 19 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index b1274ad1..113f8c77 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -28,6 +28,11 @@ WriteMakefile(
                 # We also depend on git.
                 # Keep this sorted and synced to the INSTALL document
                 'Date::Parse' => 0,
+
+                # libperl$PERL_VERSION,
+                # `perl5' on FreeBSD
+                # perl-Digest-SHA on RH-based
+                'Digest::SHA' => 0,
                 'Email::MIME' => 0,
 
                 # the following should be pulled in by Email::MIME:
@@ -44,6 +49,14 @@ WriteMakefile(
 
                 # We have more test dependencies, but do not force
                 # users to install them.  See INSTALL
+
+                # All Perl installs I know about have these, but RH-based
+                # distros make them separate even though 'perl' pulls them in
+                'File::Path' => 0,
+                'File::Temp' => 0,
+                'Getopt::Long' => 0,
+                'Exporter' => 0,
+                # ExtUtils::MakeMaker # this file won't run w/o it...
         },
         MAN3PODS => \%man3,
 );
@@ -57,14 +70,17 @@ N = \$\$(( \$\$(nproc 2>/dev/null || gnproc 2>/dev/null || echo 2) + 1 ))
 -include config.mak
 -include Documentation/include.mk
 SCRIPTS := scripts/ssoma-replay
-my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES) \$(SCRIPTS))
-
+syn_files := $PM_FILES \$(EXE_FILES) \$(SCRIPTS)
+my_syntax := \$(addsuffix .syntax, \$(syn_files))
+changed = \$(shell git ls-files -m)
 
 %.syntax ::
-        @\$(PERL) -I lib -c \$(subst .syntax,,\$@)
+        @\$(PERL) -w -I lib -c \$(subst .syntax,,\$@)
 
 syntax:: \$(my_syntax)
 
+dsyn :: \$(addsuffix .syntax, \$(filter \$(changed), \$(syn_files)))
+
 check-manifest :: MANIFEST
         if git ls-files >\$?.gen 2>&1; then diff -u \$? \$?.gen; fi