about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL25
1 files changed, 14 insertions, 11 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 904b6adf..0bac7c95 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -14,19 +14,14 @@ WriteMakefile(
         ABSTRACT => 'public-inbox server infrastructure',
         EXE_FILES => \@EXE_FILES,
         PREREQ_PM => {
-                # note: we use ssoma(1) and spamc(1), NOT the Perl modules
-                # We also depend on git through ssoma.
+                # note: we use spamc(1), NOT the Perl modules
+                # We also depend on git.
                 # Keep this sorted and synced to the INSTALL document
                 'Date::Parse' => 0,
-                'Email::Address' => 0,
-                'Email::Filter' => 0,
                 'Email::MIME' => 0,
                 'Email::MIME::ContentType' => 0,
                 'Email::Simple' => 0,
                 'Encode::MIME::Header' => 0,
-                'File::Path::Expand' => 0,
-                'IPC::Run' => 0,
-                'Mail::Thread' => '2.5', # 2.5+ needed for Email::Simple compat
                 'Plack' => 0,
                 'URI::Escape' => 0,
                 # We have more test dependencies, but do not force
@@ -36,18 +31,26 @@ WriteMakefile(
 
 sub MY::postamble {
   <<EOF;
+# support using eatmydata to speed up tests (apt-get install eatmydata):
+# https://www.flamingspork.com/projects/libeatmydata/
+EATMYDATA =
+-include config.mak
 -include Documentation/include.mk
-my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES))
+N ?= \$(shell echo \$\$(( \$\$(nproc 2>/dev/null || echo 2) + 1)))
+SCRIPTS := scripts/ssoma-replay
+my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES) \$(SCRIPTS))
 
-N := \$(shell echo \$\$(( \$\$(nproc 2>/dev/null || echo 2) + 1)))
 
 %.syntax ::
         @\$(PERL) -I lib -c \$(subst .syntax,,\$@)
 
 syntax:: \$(my_syntax)
 
-check:: pure_all
-        prove -lv -j\$(N)
+check-manifest :: MANIFEST
+        if git ls-files >\$<.gen 2>&1; then diff -u \$< \$<.gen; fi
+
+check:: pure_all check-manifest
+        \$(EATMYDATA) prove -lv -j\$(N)
 
 EOF
 }