rack-devel archive mirror (unofficial) https://groups.google.com/group/rack-devel
 help / color / mirror / code / Atom feed
* Rack Uses Regex That Occasionally Causes REE to Hang
@ 2011-07-12 23:28 John Nunemaker
  2011-07-13  0:42 ` Chris St. John
  0 siblings, 1 reply; 2+ messages in thread
From: John Nunemaker @ 2011-07-12 23:28 UTC (permalink / raw)
  To: rack-devel

[-- Attachment #1: Type: text/plain, Size: 590 bytes --]

Posted the REE issue to the REE google group as well:
https://groups.google.com/forum/#!topic/emm-ruby/EBkMfFpk40A

The regex used on line 61 in rack/backports/uri/common.rb<https://github.com/rack/rack/blob/1.3.0/lib/rack/backports/uri/common.rb#L61>causes REE to hang for certain strings. I only know because it happened in 
production over and over the past week and today, with help, I was finally 
able to track it down.

Not sure if this is really an issue with Rack or just with REE, but it will 
affect anyone using Rack 1.3.0 and REE so I thought I would mention it here 
as well.

[-- Attachment #2: Type: text/html, Size: 690 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Rack Uses Regex That Occasionally Causes REE to Hang
  2011-07-12 23:28 Rack Uses Regex That Occasionally Causes REE to Hang John Nunemaker
@ 2011-07-13  0:42 ` Chris St. John
  0 siblings, 0 replies; 2+ messages in thread
From: Chris St. John @ 2011-07-13  0:42 UTC (permalink / raw)
  To: rack-devel, nunemaker

[-- Attachment #1: Type: text/plain, Size: 967 bytes --]

I tested the regex with 1.8.7, 1.9.2, and JRuby 1.6.1.  All seem to hang and
show the same behavior you see with REE.  Seems to be an issue with Ruby's
regex engine on all distros.  FWIW, out of curiosity I ran the same regex in
Perl, which handled it quickly and correctly.

Chris

On Tue, Jul 12, 2011 at 7:28 PM, John Nunemaker <nunemaker@gmail.com> wrote:

> Posted the REE issue to the REE google group as well:
> https://groups.google.com/forum/#!topic/emm-ruby/EBkMfFpk40A
>
> The regex used on line 61 in rack/backports/uri/common.rb<https://github.com/rack/rack/blob/1.3.0/lib/rack/backports/uri/common.rb#L61>causes REE to hang for certain strings. I only know because it happened in
> production over and over the past week and today, with help, I was finally
> able to track it down.
>
> Not sure if this is really an issue with Rack or just with REE, but it will
> affect anyone using Rack 1.3.0 and REE so I thought I would mention it here
> as well.
>

[-- Attachment #2: Type: text/html, Size: 1414 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-07-13  0:42 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-07-12 23:28 Rack Uses Regex That Occasionally Causes REE to Hang John Nunemaker
2011-07-13  0:42 ` Chris St. John

Code repositories for project(s) associated with this inbox:

	https://80x24.org/mirrors/rack.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).