about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 57592378..924e8dfd 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -223,5 +223,16 @@ Makefile.PL : MANIFEST
         touch -r MANIFEST \$@
         \$(PERLRUN) \$@
 
+# Install symlinks to ~/bin (which is hopefuly in PATH) which point to
+# this source tree.
+# prefix + bindir matches git.git Makefile:
+prefix = \$(HOME)
+bindir = \$(prefix)/bin
+symlink-install :
+        mkdir -p \$(bindir)
+        lei=\$\$(realpath lei.sh) && cd \$(bindir) && \\
+        for x in \$(EXE_FILES); do \\
+                ln -sf "\$\$lei" \$\$(basename "\$\$x"); \\
+        done
 EOF
 }