about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 171712a7..4a911037 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,7 +47,10 @@ my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES) \$(SCRIPTS))
 
 syntax:: \$(my_syntax)
 
-check:: pure_all
+check-manifest :: MANIFEST
+        if git ls-files >\$<.gen 2>&1; then diff -u \$< \$<.gen; fi
+
+check:: pure_all check-manifest
         \$(EATMYDATA) prove -lv -j\$(N)
 
 EOF