about summary refs log tree commit homepage
path: root/t/altid_v2.t
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2019-01-10 04:53:10 +0000
committerEric Wong <e@80x24.org>2019-01-10 06:46:49 +0000
commit50c822076abee76c3133ffc3482488392eecedfb (patch)
tree903752fbe9b3497cfaa67a8739d901223d91f9a9 /t/altid_v2.t
parente041f5446ad266ee24e41a38e0090e2a65167606 (diff)
downloadpublic-inbox-50c822076abee76c3133ffc3482488392eecedfb.tar.gz
This allows v1 tests to continue working on git 1.8.0 for
now.  This allows git 2.1.4 packaged with Debian 8 ("jessie")
to run old tests, at least.

I suppose it's safe to drop Debian 7 ("wheezy") due to our
dependency on git 1.8.0 for "merge-base --is-ancestor".

Writing V2 repositories requires git 2.6 for "get-mark"
support, so mask out tests for older gits.
Diffstat (limited to 't/altid_v2.t')
-rw-r--r--t/altid_v2.t2
1 files changed, 2 insertions, 0 deletions
diff --git a/t/altid_v2.t b/t/altid_v2.t
index 87f1452b..e91a644c 100644
--- a/t/altid_v2.t
+++ b/t/altid_v2.t
@@ -4,6 +4,8 @@ use strict;
 use warnings;
 use Test::More;
 use File::Temp qw/tempdir/;
+require './t/common.perl';
+require_git(2.6);
 foreach my $mod (qw(DBD::SQLite Search::Xapian)) {
         eval "require $mod";
         plan skip_all => "$mod missing for altid_v2.t" if $@;