about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2020-10-27 07:54:40 +0000
committerEric Wong <e@80x24.org>2020-11-07 10:21:58 +0000
commiteecdfc84a7e605b42adf68c848ed2e16e08e963c (patch)
tree0d48dd5b8ec3368a2e1fd45a2af2603d6644bd23 /Makefile.PL
parent75bb8f5a39562f1bc5603e72338c5ed1c292362b (diff)
downloadpublic-inbox-eecdfc84a7e605b42adf68c848ed2e16e08e963c.tar.gz
But warn on it, this lets us test new or throwaway commands more
easily if we don't have to start a new POD for everything we
want to dump in script/.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index f6b7abb6..56679598 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -31,7 +31,18 @@ my @syn = (@EXE_FILES, grep(m!^lib/.*\.pm$!, @manifest), @scripts);
 @syn = grep(!/SaPlugin/, @syn) if !eval { require Mail::SpamAssasin };
 $v->{syn_files} = \@syn;
 $v->{my_syntax} = [map { "$_.syntax" } @syn];
-$v->{-m1} = [ map { (split('/'))[-1] } @EXE_FILES ];
+my @no_pod;
+$v->{-m1} = [ map {
+                my $x = (split('/'))[-1];
+                my $pod = "Documentation/$x.pod";
+                if (-f $pod) {
+                        $x;
+                } else {
+                        warn "W: $pod missing\n";
+                        push @no_pod, $x;
+                        ();
+                }
+        } @EXE_FILES ];
 $v->{-m5} = [ qw(public-inbox-config public-inbox-v1-format
                 public-inbox-v2-format) ];
 $v->{-m7} = [ qw(public-inbox-overview public-inbox-tuning) ];
@@ -109,6 +120,7 @@ my %man3 = map {; # semi-colon tells Perl this is a BLOCK (and not EXPR)
         $mod =~ s/\.\w+\z//;
         "lib/PublicInbox/$_" => "blib/man3/PublicInbox::$mod.3"
 } qw(Git.pm Import.pm WWW.pod SaPlugin/ListMirror.pod);
+my $warn_no_pod = @no_pod ? "\n\t\@echo W: missing .pod: @no_pod\n" : '';
 
 WriteMakefile(
         NAME => 'PublicInbox', # n.b. camel-case is not our choice
@@ -172,6 +184,8 @@ $VARS
 -include Documentation/include.mk
 $TGTS
 
+check-man ::$warn_no_pod
+
 # syntax checks are currently GNU make only:
 %.syntax :: %
         @\$(PERL) -w -I lib -c \$<