about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorUwe Kleine-König <uwe@kleine-koenig.org>2020-12-18 12:56:14 +0100
committerEric Wong <e@80x24.org>2020-12-18 12:10:11 +0000
commitcd12cf22c4d161b7aec819f45628b983f0bd675d (patch)
tree5f1e5981c635a10461a5f045baaac72e388b9ec7 /Makefile.PL
parentfe01d7b117c8b1e1b9fee63b9e62f399dc26f13c (diff)
downloadpublic-inbox-cd12cf22c4d161b7aec819f45628b983f0bd675d.tar.gz
On Debian (at least) perl documentation is supposed to be installed in
section 3pm. With the build system hardcoding this to 3 instead this
results in a warning by the Debian package linter:

	W: public-inbox: wrong-manual-section usr/share/man/man3/PublicInbox::Git.3.gz:74 3 != 3pm
	W: public-inbox: wrong-manual-section usr/share/man/man3/PublicInbox::Import.3.gz:74 3 != 3pm
	W: public-inbox: wrong-manual-section usr/share/man/man3/PublicInbox::SaPlugin::ListMirror.3.gz:74 3 != 3pm
	W: public-inbox: wrong-manual-section ... use --no-tag-display-limit to see all (or pipe to a file/program)

So use "$(MAN3EXT)" instead of "3".
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8e710df2..57592378 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -118,7 +118,7 @@ my %man3 = map {; # semi-colon tells Perl this is a BLOCK (and not EXPR)
         my $mod = $base;
         $mod =~ s!/!::!g;
         $mod =~ s/\.\w+\z//;
-        "lib/PublicInbox/$_" => "blib/man3/PublicInbox::$mod.3"
+        "lib/PublicInbox/$_" => "blib/man3/PublicInbox::$mod.\$(MAN3EXT)"
 } qw(Git.pm Import.pm WWW.pod SaPlugin/ListMirror.pod);
 my $warn_no_pod = @no_pod ? "\n\t\@echo W: missing .pod: @no_pod\n" : '';