about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-04-21 06:57:34 +0000
committerEric Wong <e@yhbt.net>2020-04-22 07:04:45 +0000
commita318e758129d616b3b801db82c4735c680a2fbe8 (patch)
treeba9af6a937ecf8f2a7dc339a25f1ad2a0c0ddc75 /Makefile.PL
parenta45aef4d6415553dd1f6744770b00ea9033f58d7 (diff)
downloadpublic-inbox-a318e758129d616b3b801db82c4735c680a2fbe8.tar.gz
This allows us to simplify some of our existing code and make
future changes easier.

I doubt anybody goes through the trouble to have a Perl
installation without zlib support.  The zlib source code is even
bundled with Perl since 5.9.3 for systems without existing zlib
development headers and libraries.

Of course, zlib is also a requirement of git, too; and we're not
going to stop using git :)

[squashed: "wwwaltid: use gzipfilter up front"]
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index ab24b9cf..27bb112c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -132,6 +132,11 @@ WriteMakefile(
                 # `perl5' on FreeBSD
                 'Encode' => 0,
 
+                # libperl$PERL_VERSION + perl-modules-$PERL_VERSION
+                'Compress::Raw::Zlib' => 0,
+                'Compress::Zlib' => 0,
+                'IO::Compress::Gzip' => 0,
+
                 # Plack is needed for public-inbox-httpd and PublicInbox::WWW
                 # 'Plack' => 0,