about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-05-10 19:38:23 +0000
committerEric Wong <e@yhbt.net>2020-05-10 19:43:40 +0000
commit957dfd92aacff56d323bc1d56fb99132743e958e (patch)
tree4b5ab3d543338d3a1efb2f09861d806e7f640c5d /Makefile.PL
parent9ccd182245d5924cf90a4152b032fca5b99d32e6 (diff)
downloadpublic-inbox-957dfd92aacff56d323bc1d56fb99132743e958e.tar.gz
And just treat it as a non-fatal nag when checking the rest of the
codebase.  Calling it "check-manifest" as a `make' target
preserves the old behavior, which causes the check to fail
if a file were added to the worktree without changing the
MANIFEST.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL14
1 files changed, 9 insertions, 5 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 30b8adda..472baa9b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -180,18 +180,22 @@ syntax:: \$(my_syntax)
 changed = \$(shell git ls-files -m)
 dsyn :: \$(addsuffix .syntax, \$(filter \$(changed), \$(syn_files)))
 
-check-manifest :: MANIFEST
-        if test -e .git && git ls-files >\$?.gen 2>&1; then \\
-                diff -u \$? \$?.gen; fi
+check_manifest := if test -e .git && git ls-files >MANIFEST.gen 2>&1; then \\
+                diff -u MANIFEST MANIFEST.gen; fi
+
+check-manifest : MANIFEST
+        \$(check_manifest)
 
 # the traditional way running per-*.t processes:
-check-each :: pure_all check-manifest
+check-each :: pure_all
         \$(EATMYDATA) \$(PROVE) --state=save -bvw -j\$(N)
+        -@\$(check_manifest)
 
 # lightly-tested way to run tests, relies "--state=save" in check-each
 # for best performance
-check-run :: pure_all check-manifest
+check-run :: pure_all
         \$(EATMYDATA) \$(PROVE) -bvw t/run.perl :: -j\$(N)
+        -@\$(check_manifest)
 
 check :: check-each