about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-09-19 09:37:10 +0000
committerEric Wong <e@80x24.org>2020-09-19 21:39:44 +0000
commit7c0c47e26af17918031d449d24abe40ad452f51a (patch)
treefddbc502ebf93260eb078d8490729ef4260739f2 /Makefile.PL
parent08259ae3cbc859aafa2a4bd79689b82b121ebf76 (diff)
downloadpublic-inbox-7c0c47e26af17918031d449d24abe40ad452f51a.tar.gz
This should be able to replace multiple `git cat-file' for blob
retrieval, but adjustments may be needed.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3fe9acf8..5a268362 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -71,6 +71,11 @@ $v->{gz_docs} = [ map { "$_.gz" } (@{$v->{docs}},@{$v->{docs_html}}) ];
 $v->{rsync_docs} = [ @{$v->{gz_docs}}, @{$v->{docs}},
         @{$v->{docs_html}}, qw(NEWS.atom NEWS.atom.gz)];
 
+# filter out public-inbox-gcf2 from the website, it's an internal command
+for my $var (qw(gz_docs rsync_docs)) {
+        @{$v->{$var}} = grep(!/-gcf2/, @{$v->{$var}});
+}
+
 # external manpages which we host ourselves, since some packages
 # (currently just Xapian) doesn't host manpages themselves.
 my @xman = qw(copydatabase.1 xapian-compact.1);