about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2014-04-09 18:06:34 +0000
committerEric Wong <e@80x24.org>2014-04-09 18:06:34 +0000
commit789b6e9c6de8012b556eb6d5345339eaf61f1989 (patch)
treeabf521ebf1eb0c83354cf5854245727caa48cf60 /Makefile.PL
parent394558721dd0c27f71fc6605c009ea07d37ccee8 (diff)
downloadpublic-inbox-789b6e9c6de8012b556eb6d5345339eaf61f1989.tar.gz
These tests were designed to run in parallel.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3e4f64d3..313161d4 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,5 +47,9 @@ rsync-docs:
         $(MAKE) gz-docs
         rsync --chmod=Fugo=r -av $(gz_docs) $(docs) $(RSYNC_DEST)
 
+N = $(shell echo $$(( $$(nproc 2>/dev/null || echo 2) + 1)))
+check:: pure_all
+        prove -lv -j$(N)
+
 EOF
 }