about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2021-01-24 19:53:45 -0900
committerEric Wong <e@80x24.org>2021-01-26 18:51:31 +0000
commit5683649f0956cec619cf511cd55be6ab483337d1 (patch)
tree11958e85ff9c68a7cf81d1431337b65c6ecf9c56 /Makefile.PL
parent1155c4f93dc50e3d51f5da66defc71de5b0dd274 (diff)
downloadpublic-inbox-5683649f0956cec619cf511cd55be6ab483337d1.tar.gz
This will make life easier for Debian package maintainers
running lintian.

cf. commit 1350f5ab09f72c75ac2cd6c88f6a2b9e198fef55
    ("public-inbox-v[12]-format.pod: make lexgrog happy")
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 9d0a361a..b2f3393d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -65,8 +65,12 @@ for my $i (@sections) {
                 $t->{".$m.cols : $m.$i"} = [
                         "\@echo CHECK80 $m.$i;".
                         "COLUMNS=80 \$(MAN) ./$m.$i | \$(check_man)" ];
+                $t->{".$m.lexgrog: $m.$i"} = [
+                        "\@echo LEXGROG $m.$i;" .
+                        "\$(LEXGROG) ./$m.$i >\$\@+ && mv \$\@+ \$@" ];
         }
         push @{$v->{check_80}}, map { ".$_.cols" } @$ary;
+        push @{$v->{check_lexgrog}}, map { ".$_.lexgrog" } @$ary;
         my $manuals = $v->{"man$i"} = [ map { "$_.$i" } @$ary ];
         push @{$v->{manuals}}, @$manuals;
         push @{$v->{mantxt}}, map { "Documentation/$_.txt" } @$ary;
@@ -121,6 +125,8 @@ my %man3 = map {; # semi-colon tells Perl this is a BLOCK (and not EXPR)
         "lib/PublicInbox/$_" => "blib/man3/PublicInbox::$mod.\$(MAN3EXT)"
 } qw(Git.pm Import.pm WWW.pod SaPlugin/ListMirror.pod);
 my $warn_no_pod = @no_pod ? "\n\t\@echo W: missing .pod: @no_pod\n" : '';
+chomp(my $lexgrog = `which lexgrog 2>/dev/null`);
+my $check_lexgrog = $lexgrog ? 'check-lexgrog' : '';
 
 WriteMakefile(
         NAME => 'PublicInbox', # n.b. camel-case is not our choice
@@ -184,7 +190,7 @@ $VARS
 -include Documentation/include.mk
 $TGTS
 
-check-man ::$warn_no_pod
+check-man :: $check_lexgrog$warn_no_pod
 
 # syntax checks are currently GNU make only:
 %.syntax :: %