about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-01-05 23:23:35 +0000
committerEric Wong <e@yhbt.net>2020-01-06 10:21:00 +0000
commit55b707d788ce13696e4411389583e720ea6dab01 (patch)
tree19fcea9f3da92c0183fdb5845c79aaefbe1d53c4 /Makefile.PL
parent42f390c5e4d8e6619d234a43aa5397c9977cf070 (diff)
downloadpublic-inbox-55b707d788ce13696e4411389583e720ea6dab01.tar.gz
There's a bunch of leftover "require" and "use" statements we no
longer need and can get rid of, along with some excessive
imports via "use".

IO::Handle usage isn't always obvious, so add comments
describing why a package loads it.  Along the same lines,
document the tmpdir support as the reason we depend on
File::Temp 0.19, even though every Perl 5.10.1+ user has it.

While we're at it, favor "use" over "require", since it it gives
us extra compile-time checking.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index b8c05cf7..3492d965 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -137,7 +137,7 @@ WriteMakefile(
                 # All Perl installs I know about have these, but RH-based
                 # distros make them separate even though 'perl' pulls them in
                 'File::Path' => 0,
-                'File::Temp' => '0.19',
+                'File::Temp' => '0.19', # for ->tmpdir support
                 'Getopt::Long' => 0,
                 'Exporter' => 0,
                 # ExtUtils::MakeMaker # this file won't run w/o it...