about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2021-01-01 05:10:57 +0000
committerEric Wong <e@80x24.org>2021-01-01 05:10:57 +0000
commit35ea5266bf71747c3ebec638fd53e23a2522908e (patch)
tree954261fb9a94ebf508d4f2ce760351c13db40232 /Makefile.PL
parent0d6777e0389fe2db3edce41d675320746433f5b7 (diff)
downloadpublic-inbox-35ea5266bf71747c3ebec638fd53e23a2522908e.tar.gz
It might save me a few cycles every year to not have to
scroll through git history to see how it's run.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 924e8dfd..613a72ae 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,5 +1,5 @@
 #!/usr/bin/perl -w
-# Copyright (C) 2013-2020 all contributors <meta@public-inbox.org>
+# Copyright (C) 2013-2021 all contributors <meta@public-inbox.org>
 # License: AGPL-3.0+ <https://www.gnu.org/licenses/agpl-3.0.txt>
 use strict;
 use ExtUtils::MakeMaker;
@@ -234,5 +234,11 @@ symlink-install :
         for x in \$(EXE_FILES); do \\
                 ln -sf "\$\$lei" \$\$(basename "\$\$x"); \\
         done
+
+update-copyrights :
+        \@case '\$(GNULIB_PATH)' in '') echo >&2 GNULIB_PATH unset; false;; esac
+        git ls-files | UPDATE_COPYRIGHT_HOLDER='all contributors' \\
+                UPDATE_COPYRIGHT_USE_INTERVALS=2 \\
+                xargs \$(GNULIB_PATH)/build-aux/update-copyright
 EOF
 }