about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2021-11-03 21:01:21 +0000
committerEric Wong <e@80x24.org>2021-11-04 03:29:33 +0000
commit0b73ad048e715065efc3ed3eb1c376e945957693 (patch)
treeb0c3fa1fe372448817f4b028c2214be96645ad9c /Makefile.PL
parent59f48f29b59a941acc620cef1062e7249b92c528 (diff)
downloadpublic-inbox-0b73ad048e715065efc3ed3eb1c376e945957693.tar.gz
curl, torsocks, and gitglossary manpages are all newly
referenced, so make sure they're linkified properly in HTML.
We'll be using Debian's manpages as an ad-free, Tor-accessible
host for manpages as a fallback since hosting manpages for all
3rd-party projects we reference doesn't scale.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL17
1 files changed, 0 insertions, 17 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8c8c0235..b7851ada 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -101,23 +101,6 @@ $v->{gz_docs} = [ map { "$_.gz" } (@{$v->{docs}},@{$v->{docs_html}}) ];
 $v->{rsync_docs} = [ @{$v->{gz_docs}}, @{$v->{docs}},
         @{$v->{docs_html}}, qw(NEWS.atom NEWS.atom.gz)];
 
-# external manpages which we host ourselves, since some packages
-# (currently just Xapian) doesn't host manpages themselves.
-my @xman = qw(copydatabase.1 xapian-compact.1);
-$v->{xdocs} = [ map { "Documentation/.$_.txt" } @xman ];
-$v->{xdocs_html} = [ map { "Documentation/.$_.html" } @xman ];
-for (@{$v->{xdocs}}) {
-        $t->{"$_:"} = [
-                '$(PERL) -w Documentation/extman.perl $@ >$@+',
-                'mv $@+ $@'
-        ];
-        my $html = $_;
-        $html =~ s/\.txt\z/.html/;
-        $t->{"$html : $_"} = [ "\$(txt2pre) <$_" ];
-}
-$v->{gz_xdocs} = [ map { "$_.gz" } (@{$v->{xdocs_html}}, @{$v->{xdocs}}) ];
-$v->{rsync_xdocs} = [ @{$v->{gz_xdocs}}, @{$v->{xdocs_html}}, @{$v->{xdocs}} ];
-
 my $TGTS = join("\n", map {;
         my $tgt_prereq = $_;
         my $cmds = $t->{$_};