about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-08-08 11:24:05 +0000
committerEric Wong <e@yhbt.net>2020-08-09 18:41:42 +0000
commitc538c9593e4c4d8185c3131eab2d14c383fafe8f (patch)
tree7199fcb0f9bc53e1757e2740aacbdd8a953d72b0 /Makefile.PL
parent5458d831698f79c58adf955dc11753d3b560374d (diff)
downloadpublic-inbox-c538c9593e4c4d8185c3131eab2d14c383fafe8f.tar.gz
getconf(1) itself is POSIX, while `_NPROCESSORS_ONLN' is not.
However, FreeBSD (tested 11.4 and 12.1) and glibc (tested CentOS
7.x and Debian 10.x) both support `getconf _NPROCESSORS_ONLN'.

GNU coreutils (and thus `nproc' or `gnproc') are not installed
by default on the *BSDs, so we'll try the option most likely
to exist on both glibc and *BSDs out-of-the-box.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8d90ad46..831649f9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -156,12 +156,14 @@ WriteMakefile(
 );
 
 sub MY::postamble {
-  <<EOF;
+        my $N = (`{ getconf _NPROCESSORS_ONLN || nproc; } 2>/dev/null` || 1);
+        $N += 1; # account for sleeps in some tests (and makes an IV)
+        <<EOF;
 PROVE = prove
 # support using eatmydata to speed up tests (apt-get install eatmydata):
 # https://www.flamingspork.com/projects/libeatmydata/
 EATMYDATA =
-N = \$\$(( \$\$(nproc 2>/dev/null || gnproc 2>/dev/null || echo 2) + 1 ))
+N = $N
 -include config.mak
 $VARS
 -include Documentation/include.mk