about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2019-06-13 03:44:41 +0000
committerEric Wong <e@80x24.org>2019-06-13 03:45:23 +0000
commit9bcbfbd478b961786586099af6e6c14775b3827c (patch)
tree65208e32b99d4427600d4bd7931682e5b298f190 /Makefile.PL
parentf4dbd80157bd785cf5d863d517b7334bd2795bab (diff)
downloadpublic-inbox-9bcbfbd478b961786586099af6e6c14775b3827c.tar.gz
We have lots of files and syntax-checking every single one of
them is slow.  Enable "perl -w" in the existing syntax check
while we're at it.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 341d42af..113f8c77 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -70,14 +70,17 @@ N = \$\$(( \$\$(nproc 2>/dev/null || gnproc 2>/dev/null || echo 2) + 1 ))
 -include config.mak
 -include Documentation/include.mk
 SCRIPTS := scripts/ssoma-replay
-my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES) \$(SCRIPTS))
-
+syn_files := $PM_FILES \$(EXE_FILES) \$(SCRIPTS)
+my_syntax := \$(addsuffix .syntax, \$(syn_files))
+changed = \$(shell git ls-files -m)
 
 %.syntax ::
-        @\$(PERL) -I lib -c \$(subst .syntax,,\$@)
+        @\$(PERL) -w -I lib -c \$(subst .syntax,,\$@)
 
 syntax:: \$(my_syntax)
 
+dsyn :: \$(addsuffix .syntax, \$(filter \$(changed), \$(syn_files)))
+
 check-manifest :: MANIFEST
         if git ls-files >\$?.gen 2>&1; then diff -u \$? \$?.gen; fi