user/dev discussion of public-inbox itself
 help / color / mirror / code / Atom feed
Search results ordered by [date|relevance]  view[summary|nested|Atom feed]
thread overview below | download mbox.gz: |
* [PATCH 2/2] daemon: favor Socket.pm in Perl 5.14+ for IPv6
  2019-02-06 11:07  6% [PATCH 0/2] try harder to avoid Socket6 dependency Eric Wong
@ 2019-02-06 11:07  7% ` Eric Wong
  0 siblings, 0 replies; 2+ results
From: Eric Wong @ 2019-02-06 11:07 UTC (permalink / raw)
  To: meta

Users on Perl 5.14+ are common, so we can try the bundled Socket
(not "Socket6") module before attempting Socket6 for IPv6.
---
 INSTALL                   |  3 ++-
 lib/PublicInbox/Daemon.pm | 21 ++++++++++++++-------
 2 files changed, 16 insertions(+), 8 deletions(-)

diff --git a/INSTALL b/INSTALL
index a89c890..ce2f8c9 100644
--- a/INSTALL
+++ b/INSTALL
@@ -107,7 +107,8 @@ Numerous optional modules are likely to be useful as well:
                                rpm: perl-Socket6
                                (pulled in by SpamAssassin and Net::Server,
                                 only necessary if using IPv6 with
-                                Plack::Middleware::AccessLog or similar)
+                                Plack::Middleware::AccessLog or similar
+                                on Perl <= 5.12)
 
 On Fedora systems, you'll probably also end up wanting
 perl-Test-HTTP-Server-Simple, perl-Devel-Peek, and perl-IPC-Run to run the
diff --git a/lib/PublicInbox/Daemon.pm b/lib/PublicInbox/Daemon.pm
index 033dd98..48051f4 100644
--- a/lib/PublicInbox/Daemon.pm
+++ b/lib/PublicInbox/Daemon.pm
@@ -236,16 +236,23 @@ sub sockname ($) {
 
 sub unpack_ipv6 ($) {
 	my ($addr) = @_;
+	my ($port, $host);
 
-	# TODO: support IO::Socket::IP which comes with Perl 5.24
-	# (perl-modules-5.24 in Debian)
+	# Socket.pm in Perl 5.14+ supports IPv6:
+	eval {
+		($port, $host) = Socket::unpack_sockaddr_in6($addr);
+		$host = Socket::inet_ntop(Socket::AF_INET6(), $host);
+	};
 
-	# SpamAssassin and Net::Server use Socket6, so it may be installed
-	# on our system, already (otherwise die):
-	require Socket6;
+	if ($@) {
+		# Perl 5.12 or earlier?  SpamAssassin and Net::Server use
+		# Socket6, so it may be installed on our system, already
+		# (otherwise die here):
+		require Socket6;
 
-	my ($port, $host) = Socket6::unpack_sockaddr_in6($addr);
-	$host = Socket6::inet_ntop(Socket6::AF_INET6(), $host);
+		($port, $host) = Socket6::unpack_sockaddr_in6($addr);
+		$host = Socket6::inet_ntop(Socket6::AF_INET6(), $host);
+	}
 	($host, $port);
 }
 
-- 
EW


^ permalink raw reply	[relevance 7%]

* [PATCH 0/2] try harder to avoid Socket6 dependency
@ 2019-02-06 11:07  6% Eric Wong
  2019-02-06 11:07  7% ` [PATCH 2/2] daemon: favor Socket.pm in Perl 5.14+ for IPv6 Eric Wong
  0 siblings, 1 reply; 2+ results
From: Eric Wong @ 2019-02-06 11:07 UTC (permalink / raw)
  To: meta

Since I reckon Perl 5.14+ is pretty common, favoring the
bundled Socket.pm is advantageous in reducing installation
overhead and memory use, since we already rely on "Socket"
being loaded.

*** BLURB HERE ***

Eric Wong (2):
  daemon: die properly when Socket6 is missing
  daemon: favor Socket.pm in Perl 5.14+ for IPv6

 INSTALL                   |  3 ++-
 lib/PublicInbox/Daemon.pm | 21 ++++++++++++++-------
 2 files changed, 16 insertions(+), 8 deletions(-)

-- 
EW


^ permalink raw reply	[relevance 6%]

Results 1-2 of 2 | reverse | sort options + mbox downloads above
-- links below jump to the message on this page --
2019-02-06 11:07  6% [PATCH 0/2] try harder to avoid Socket6 dependency Eric Wong
2019-02-06 11:07  7% ` [PATCH 2/2] daemon: favor Socket.pm in Perl 5.14+ for IPv6 Eric Wong

Code repositories for project(s) associated with this inbox:

	https://80x24.org/public-inbox.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).