user/dev discussion of public-inbox itself
 help / color / mirror / code / Atom feed
From: Eric Wong <>
To: Alyssa Ross <>
Subject: Re: public-inbox-init with minimal info
Date: Thu, 10 Oct 2019 08:19:24 +0000	[thread overview]
Message-ID: <20191010081924.GA14812@ailurophile> (raw)
In-Reply-To: <>

Alyssa Ross <> wrote:
> >> >>     services.public-inbox.http.mount = "/lists/archives/";
> >> >
> >> > I think all the services would want access to the same
> >> > directories, not just httpd (if I'm understanding that config
> >> > correctly).  Also, httpd/nntpd only need read-only access to their
> >> > mount points, in case that affects things...
> >> 
> >> "mount" here is in the PSGI sense, not the file system sense.  My
> >> public-inboxes are at  Maybe
> >> there's a better name.
> >
> > Ah, so that overrides the Plack::Builder DSL/language.  We also
> > have an analogous support problem for PSGI vs public-inbox-config,
> > so I've been avoiding any overlap between them.
> >
> > Perhaps "psgi_mount" would be clearer? *shrug*
> I shied away from that because it would only be clearer if you know what
> PSGI is, and the module takes care of all of that.  I also considered
> httpMount, but since it's already in the http namespace that felt
> redundant.

Maybe "url_mount"?  Naming is one of the toughest problems :<

> > Btw, would it be helpful if public-inbox provided a linter for
> > its config own file?
> Very much so!  That would let us lint config files at build time, and
> fail the system build if they were invalid, meaning a system could
> "never" have an invalid config file.  We already do this with nginx --
> the linter doesn't catch everything, but it's wonderful when it catches
> something that would otherwise have left you without a working web
> server.

OK, adding TODO item.

> Here's an idea for a lint: I lost most of a day wondering what I had
> done wrong, before realising that I was setting mainrepo to all.git,
> rather than its parent directory.  The name "mainrepo" isn't great, IMO,
> but a lint could have accomodated for that.

Sorry about wasting your time!  Yeah, "mainrepo" is a bad name,
especially with v2 :<

I guess we can shift to "inboxdir" and keep the old alias
indefinitely for compatibility, since there's already INBOX_DIR
all over the documentation.

I originally intended for each inbox to have another repo
for rejected/spam messages; but just put it in PI_EMERGENCY,

  reply	other threads:[~2019-10-10  8:19 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-03 11:16 public-inbox-init with minimal info Alyssa Ross
2019-10-04  2:45 ` Eric Wong
2019-10-04 11:18   ` Alyssa Ross
2019-10-05  5:14     ` Eric Wong
2019-10-05 13:05       ` Alyssa Ross
2019-10-05 19:58         ` Eric Wong
2019-10-06  9:52           ` Alyssa Ross
2019-10-06 12:01             ` Eric Wong
2019-10-07 20:52               ` Alyssa Ross
2019-10-08  7:11                 ` Eric Wong
2019-10-09 12:09                   ` Alyssa Ross
2019-10-10  8:19                     ` Eric Wong [this message]
2019-10-16 10:04                       ` Eric Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191010081924.GA14812@ailurophile \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).