From: Johannes Schindelin <Johannes.Schindelin@gmx.de>
To: Junio C Hamano <gitster@pobox.com>
Cc: Liam Beguin <liambeguin@gmail.com>,
git@vger.kernel.org, avarab@gmail.com
Subject: Re: [PATCH 3/5] rebase -i: add exec commands via the rebase--helper
Date: Mon, 27 Nov 2017 22:41:37 +0100 (CET) [thread overview]
Message-ID: <alpine.DEB.2.21.1.1711272230490.6482@virtualbox> (raw)
In-Reply-To: <xmqq609we20v.fsf@gitster.mtv.corp.google.com>
Hi Junio,
On Mon, 27 Nov 2017, Junio C Hamano wrote:
> Liam Beguin <liambeguin@gmail.com> writes:
>
> > diff --git a/sequencer.c b/sequencer.c
> > index fa94ed652d2c..810b7850748e 100644
> > --- a/sequencer.c
> > +++ b/sequencer.c
> > @@ -2492,6 +2492,52 @@ int sequencer_make_script(int keep_empty, FILE *out,
> > return 0;
> > }
> >
> > +int add_exec_commands(const char *command)
> > +{
>
> As the name of a public function, it does not feel that this hints
> it strongly enough that it is from and a part of sequencer.c API.
How about a "yes, and" instead? As in:
To further improve this patch, let's use the name
sequencer_add_exec_commands() for this function because it is defined
globally now.
> > + const char *todo_file = rebase_path_todo();
> > + struct todo_list todo_list = TODO_LIST_INIT;
> > + int fd, res, i, first = 1;
> > + FILE *out;
>
> Having had to scan backwards while trying to see what the loop that
> uses this variable is doing and if it gets affected by things that
> happened before we entered the loop, I'd rather not to see 'first'
> initialized here, left unused for quite some time until the loop is
> entered. It would make it a lot easier to follow if it is declared
> and left uninitilized here, and set to 1 immediately before the
> for() loop that uses it.
Funny, I would have assumed it the other way round: since "first" always
has to be initialized with 1, I would have been surprised to see an
explicit assignment much later than it is declared.
> > + strbuf_reset(&todo_list.buf);
> > + fd = open(todo_file, O_RDONLY);
> > + if (fd < 0)
> > + return error_errno(_("could not open '%s'"), todo_file);
> > + if (strbuf_read(&todo_list.buf, fd, 0) < 0) {
> > + close(fd);
> > + return error(_("could not read '%s'."), todo_file);
> > + }
> > + close(fd);
>
> Is this strbuf_read_file() written in longhand?
Ah, this is one of the downsides of patch-based review. If it was reviewed
in context, you would have easily spotted that Liam was merely
copy-editing my code that is still around.
And indeed, I had missed that function when I started to write the
rebase--helper patches.
> > + res = parse_insn_buffer(todo_list.buf.buf, &todo_list);
> > + if (res) {
> > + todo_list_release(&todo_list);
> > + return error(_("unusable todo list: '%s'"), todo_file);
> > + }
> > +
> > + out = fopen(todo_file, "w");
> > + if (!out) {
> > + todo_list_release(&todo_list);
> > + return error(_("unable to open '%s' for writing"), todo_file);
> > + }
> > + for (i = 0; i < todo_list.nr; i++) {
> > + struct todo_item *item = todo_list.items + i;
> > + int bol = item->offset_in_buf;
> > + const char *p = todo_list.buf.buf + bol;
> > + int eol = i + 1 < todo_list.nr ?
> > + todo_list.items[i + 1].offset_in_buf :
> > + todo_list.buf.len;
>
> Should bol and eol be of type size_t instead? The values that get
> assigned to them from other structures are.
While it won't matter in practice, this would be "more correct" to do,
yes.
Ciao,
Dscho
next prev parent reply other threads:[~2017-11-27 21:42 UTC|newest]
Thread overview: 70+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-27 4:55 [PATCH 0/5] rebase -i: add config to abbreviate command names Liam Beguin
2017-11-27 4:55 ` [PATCH 1/5] Documentation: move rebase.* configs to new file Liam Beguin
2017-11-27 21:27 ` Johannes Schindelin
2017-11-27 4:55 ` [PATCH 2/5] Documentation: use preferred name for the 'todo list' script Liam Beguin
2017-11-27 21:28 ` Johannes Schindelin
2017-11-27 4:55 ` [PATCH 3/5] rebase -i: add exec commands via the rebase--helper Liam Beguin
2017-11-27 5:14 ` Junio C Hamano
2017-11-27 21:41 ` Johannes Schindelin [this message]
2017-11-27 23:45 ` Junio C Hamano
2017-11-29 2:01 ` liam Beguin
2017-11-27 22:42 ` Johannes Schindelin
2017-11-27 23:48 ` Junio C Hamano
2017-11-29 2:06 ` liam Beguin
2017-11-29 21:35 ` Johannes Schindelin
2017-11-27 4:55 ` [PATCH 4/5] rebase -i: learn to abbreviate command names Liam Beguin
2017-11-27 5:19 ` Junio C Hamano
2017-11-29 2:08 ` liam Beguin
2017-11-27 23:04 ` Johannes Schindelin
2017-11-27 23:11 ` Jeff King
2017-11-29 2:11 ` liam Beguin
2017-11-29 2:10 ` liam Beguin
2017-11-29 21:40 ` Johannes Schindelin
2017-12-03 1:18 ` Junio C Hamano
2017-11-27 4:55 ` [PATCH 5/5] t3404: add test case for abbreviated commands Liam Beguin
2017-11-27 5:28 ` Junio C Hamano
2017-11-27 23:16 ` Johannes Schindelin
2017-11-27 5:23 ` [PATCH 0/5] rebase -i: add config to abbreviate command names Junio C Hamano
2017-11-29 1:56 ` liam Beguin
2017-12-03 22:17 ` [PATCH v2 0/9] " Liam Beguin
2017-12-03 22:17 ` [PATCH v2 1/9] Documentation: move rebase.* configs to new file Liam Beguin
2017-12-03 22:17 ` [PATCH v2 2/9] Documentation: use preferred name for the 'todo list' script Liam Beguin
2017-12-03 22:17 ` [PATCH v2 3/9] rebase -i: set commit to null in exec commands Liam Beguin
2017-12-03 22:17 ` [PATCH v2 4/9] rebase -i: refactor transform_todo_ids Liam Beguin
2017-12-04 14:42 ` Johannes Schindelin
2017-12-04 16:09 ` Junio C Hamano
2017-12-05 3:36 ` liam Beguin
2017-12-05 12:35 ` Junio C Hamano
2017-12-05 3:39 ` liam Beguin
2017-12-03 22:17 ` [PATCH v2 5/9] rebase -i: replace reference to sha1 with oid Liam Beguin
2017-12-03 22:17 ` [PATCH v2 6/9] rebase -i: update functions to use a flags parameter Liam Beguin
2017-12-04 15:46 ` Johannes Schindelin
2017-12-04 16:06 ` Johannes Schindelin
2017-12-05 3:42 ` liam Beguin
2017-12-05 12:37 ` Junio C Hamano
2017-12-05 12:41 ` Kerry, Richard
2017-12-05 14:42 ` liam Beguin
2017-12-05 16:05 ` Junio C Hamano
2017-12-05 16:14 ` Kerry, Richard
2017-12-03 22:17 ` [PATCH v2 7/9] rebase -i -x: add exec commands via the rebase--helper Liam Beguin
2017-12-03 22:17 ` [PATCH v2 8/9] rebase -i: learn to abbreviate command names Liam Beguin
2017-12-25 12:48 ` Duy Nguyen
2017-12-25 15:39 ` Liam Beguin
2017-12-25 23:58 ` Duy Nguyen
2017-12-27 19:15 ` Junio C Hamano
2017-12-27 21:58 ` Liam Beguin
2017-12-28 18:55 ` Junio C Hamano
2017-12-03 22:17 ` [PATCH v2 9/9] t3404: add test case for abbreviated commands Liam Beguin
2017-12-04 16:07 ` [PATCH v2 0/9] rebase -i: add config to abbreviate command names Johannes Schindelin
2017-12-05 17:52 ` Liam Beguin
2017-12-05 17:52 ` [PATCH v3 1/9] Documentation: move rebase.* configs to new file Liam Beguin
2017-12-05 17:52 ` [PATCH v3 2/9] Documentation: use preferred name for the 'todo list' script Liam Beguin
2017-12-05 17:52 ` [PATCH v3 3/9] rebase -i: set commit to null in exec commands Liam Beguin
2017-12-05 17:52 ` [PATCH v3 4/9] rebase -i: refactor transform_todo_ids Liam Beguin
2017-12-05 17:52 ` [PATCH v3 5/9] rebase -i: replace reference to sha1 with oid Liam Beguin
2017-12-05 17:52 ` [PATCH v3 6/9] rebase -i: update functions to use a flags parameter Liam Beguin
2017-12-05 17:52 ` [PATCH v3 7/9] rebase -i -x: add exec commands via the rebase--helper Liam Beguin
2017-12-05 17:52 ` [PATCH v3 8/9] rebase -i: learn to abbreviate command names Liam Beguin
2017-12-05 17:52 ` [PATCH v3 9/9] t3404: add test case for abbreviated commands Liam Beguin
2017-12-05 22:21 ` [PATCH v2 0/9] rebase -i: add config to abbreviate command names Junio C Hamano
2017-12-06 2:42 ` liam Beguin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
List information: http://vger.kernel.org/majordomo-info.html
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.21.1.1711272230490.6482@virtualbox \
--to=johannes.schindelin@gmx.de \
--cc=avarab@gmail.com \
--cc=git@vger.kernel.org \
--cc=gitster@pobox.com \
--cc=liambeguin@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
Code repositories for project(s) associated with this public inbox
https://80x24.org/mirrors/git.git
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).