git@vger.kernel.org list mirror (unofficial, one of many)
 help / color / mirror / code / Atom feed
* submodule cloning issue
@ 2020-04-14 18:23 Brian Walsh
  0 siblings, 0 replies; only message in thread
From: Brian Walsh @ 2020-04-14 18:23 UTC (permalink / raw)
  To: git

I am seeing a problem with cloning a repo with submodules while on my
company vpn. One of the submodule urls has an http redirect. It will
timeout trying to clone that redirected submodule and only that
submodule. I would say that it is solely an issue with my company vpn
however I can do a git clone of the repo that is failing and it does
properly redirect and clone. So there is a difference in how git
submodule--helper clone works vs git clone. If I drop off of the vpn
it works without any problem.

I am seeing the issue with version 2.25 and 2.26 running under ubuntu.

I have not had time to dig into it further to see what is going on.

Here is the repo that is having issues.

https://github.com/ycm-core/YouCompleteMe.git

This submodule that is buried in there is redirected to a new url. It
will hang trying to submodule clone.
https://github.com/mitsuhiko/flask-sphinx-themes.git

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2020-04-14 18:24 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-14 18:23 submodule cloning issue Brian Walsh

Code repositories for project(s) associated with this inbox:

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).