git@vger.kernel.org mailing list mirror (one of many)
 help / color / mirror / code / Atom feed
From: "Ævar Arnfjörð Bjarmason" <avarab@gmail.com>
To: Jonathan Nieder <jrnieder@gmail.com>
Cc: Junio C Hamano <gitster@pobox.com>,
	Elijah Newren <newren@gmail.com>,
	git@vger.kernel.org
Subject: Re: [PATCHv4 02/15] t4017 (diff-retval): replace manual exit code check with test_expect_code
Date: Fri, 1 Oct 2010 10:38:32 +0000	[thread overview]
Message-ID: <AANLkTinqVTqxiHL5tEv+-SS6YURGUoWaPxCgpccZgjEq@mail.gmail.com> (raw)
In-Reply-To: <20101001102315.GA6816@burratino>

On Fri, Oct 1, 2010 at 10:23, Jonathan Nieder <jrnieder@gmail.com> wrote:
> Ævar Arnfjörð Bjarmason wrote:
>> On Wed, Sep 29, 2010 at 18:07, Junio C Hamano <gitster@pobox.com> wrote:
>>> Elijah Newren <newren@gmail.com> writes:
>
>>>> -test_expect_success 'git diff-tree HEAD^ HEAD' '
>>>> +test_expect_code 1 'git diff-tree HEAD^ HEAD' '
>>>>       git diff-tree --exit-code HEAD^ HEAD
>>>> -     test $? = 1
>>>>  '
>>
>> It also looks like this will pass for for all exit codes that *aren't*
>> 1, because if $? != 1 +test_expect_code will get the exit code of
>> 1.
>
> You probably missed the - indicating that the "test $? = 1" was being
> removed.

Correct. I misread that.

> +check_exit_status () {
> +       echo "$1" >expect.status
> +       shift
> +       "$@"
> +       echo "$?" >actual.status
> +       test_cmp expect.status actual.status
> +}

If we add this it should be in the test-lib.sh, it'll probably be
useful for other tests.

>  test_expect_success 'setup' '
>        echo "1 " >a &&
>        git add . &&
> @@ -21,110 +29,81 @@ test_expect_success 'git diff --quiet -w  HEAD^^ HEAD^' '
>  '
>
>  test_expect_success 'git diff --quiet HEAD^^ HEAD^' '
> -       test_must_fail git diff --quiet HEAD^^ HEAD^
> +       check_exit_status 1 git diff --quiet HEAD^^ HEAD^
>  '

In most uses of check_exit_status you're using it is the very last
command within a test_expect_success. Isn't it redundant to using just
"test_expect_code $code ..." there?

>  test_expect_success 'check detects leftover conflict markers' '
> @@ -133,10 +112,8 @@ test_expect_success 'check detects leftover conflict markers' '
>        echo binary >>b &&
>        git commit -m "side" b &&
>        test_must_fail git merge master &&
> -       git add b && (
> -               git --no-pager diff --cached --check >test.out
> -               test $? = 2
> -       ) &&
> +       git add b &&
> +       check_exit_status 2 git --no-pager diff --cached --check >test.out &&
>        test 3 = $(grep "conflict marker" test.out | wc -l) &&
>        git reset --hard
>  '

But of course in cases like these it's needed.

In any case, we only use test_expect_code for two tests in the whole
test suite now, and checking the exit status for individual commands
is more self-documenting and less prone to break if we add more tests
to a given test.

So IMO the best thing to do would be to re-appropriate
"test_expect_code" so that it runs inside a test (i.e. does what your
check_exit_status does), and not at the top-level.

Then do s/check_exit_status/test_expect_code/g on your patch, and
change the tests using test_expect_code in t1504-ceiling-dirs.sh and
t6020-merge-df.sh to use test_expect_success + test_expect_code.

  reply	other threads:[~2010-10-01 10:38 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-09-26 23:14 [PATCHv4 00/15] Add missing &&'s in the testsuite Elijah Newren
2010-09-26 23:14 ` [PATCHv4 01/15] t3020 (ls-files-error-unmatch): remove stray '1' from end of file Elijah Newren
2010-09-26 23:14 ` [PATCHv4 02/15] t4017 (diff-retval): replace manual exit code check with test_expect_code Elijah Newren
2010-09-29 18:07   ` Junio C Hamano
2010-09-29 18:45     ` Ævar Arnfjörð Bjarmason
2010-10-01 10:23       ` Jonathan Nieder
2010-10-01 10:38         ` Ævar Arnfjörð Bjarmason [this message]
2010-10-01 11:52           ` Jonathan Nieder
2010-10-01 16:20           ` Junio C Hamano
2010-10-01 17:16             ` [PATCH] test-lib: make test_expect_code a test command Ævar Arnfjörð Bjarmason
2010-10-01 17:39               ` Sverre Rabbelier
2010-10-01 17:46                 ` Ævar Arnfjörð Bjarmason
2010-10-01 17:47                   ` Sverre Rabbelier
2010-10-01 17:42               ` [PATCH v2] " Ævar Arnfjörð Bjarmason
2010-10-01 18:55               ` [PATCH] " Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 03/15] t100[12] (read-tree-m-2way, read_tree_m_u_2way): add missing && Elijah Newren
2010-09-29 18:28   ` Junio C Hamano
2010-10-01 10:27     ` Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 04/15] t4002 (diff-basic): use test_might_fail for commands that might fail Elijah Newren
2010-10-01 10:35   ` Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 05/15] t4202 (log): Replace '<git-command> || :' with test_might_fail Elijah Newren
2010-09-26 23:14 ` [PATCHv4 06/15] t3600 (rm): add lots of missing && Elijah Newren
2010-10-01 10:48   ` Jonathan Nieder
2010-10-03  2:47     ` Elijah Newren
2010-09-26 23:14 ` [PATCHv4 07/15] t4019 (diff-wserror): " Elijah Newren
2010-09-29 19:01   ` Junio C Hamano
2010-10-03  3:03     ` Elijah Newren
2010-10-01 11:00   ` Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 08/15] t4026 (color): remove unneeded and unchained command Elijah Newren
2010-09-26 23:14 ` [PATCHv4 09/15] t5602 (clone-remote-exec): add missing && Elijah Newren
2010-09-29 19:09   ` Junio C Hamano
2010-10-01 11:34     ` Jonathan Nieder
2010-10-03  3:08       ` Elijah Newren
2010-09-26 23:14 ` [PATCHv4 10/15] t6016 (rev-list-graph-simplify-history): " Elijah Newren
2010-09-27  0:10   ` Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 11/15] t7001 (mv): " Elijah Newren
2010-09-26 23:14 ` [PATCHv4 12/15] t7601 (merge-pull-config): " Elijah Newren
2010-09-26 23:14 ` [PATCHv4 13/15] t7800 (difftool): " Elijah Newren
2010-10-01 11:30   ` Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 14/15] Add missing &&'s throughout the testsuite Elijah Newren
2010-09-29 19:37   ` Junio C Hamano
2010-10-01  0:48   ` Ævar Arnfjörð Bjarmason
2010-10-01 11:26   ` Jonathan Nieder
2010-09-26 23:14 ` [PATCHv4 15/15] Replace "unset VAR" with "unset VAR;" in testsuite as per t/README Elijah Newren
2010-09-29 19:48   ` Junio C Hamano
2010-09-29 20:28     ` Ævar Arnfjörð Bjarmason
2010-09-29 20:30     ` Elijah Newren
2010-09-30 16:09       ` Junio C Hamano
2010-09-30 21:51         ` Elijah Newren
2010-10-01 11:45           ` Jonathan Nieder
2010-10-01 14:39             ` Sverre Rabbelier

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: http://vger.kernel.org/majordomo-info.html

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=AANLkTinqVTqxiHL5tEv+-SS6YURGUoWaPxCgpccZgjEq@mail.gmail.com \
    --to=avarab@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=jrnieder@gmail.com \
    --cc=newren@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).