messages from 2020-12-05 01:57:10 to 2020-12-08 00:06:39 UTC [more...]
[PATCH 00/23] pack-bitmap: bitmap generation improvements
2020-12-08 0:05 UTC (25+ messages)
` [PATCH v3 00/24] "
` [PATCH v3 01/24] ewah/ewah_bitmap.c: avoid open-coding ALLOC_GROW()
` [PATCH v3 02/24] pack-bitmap: fix header size check
` [PATCH v3 03/24] pack-bitmap: bounds-check size of cache extension
` [PATCH v3 04/24] t5310: drop size of truncated ewah bitmap
` [PATCH v3 05/24] rev-list: die when --test-bitmap detects a mismatch
` [PATCH v3 06/24] ewah: factor out bitmap growth
` [PATCH v3 07/24] ewah: make bitmap growth less aggressive
` [PATCH v3 08/24] ewah: implement bitmap_or()
` [PATCH v3 09/24] ewah: add bitmap_dup() function
` [PATCH v3 10/24] pack-bitmap-write: reimplement bitmap writing
` [PATCH v3 11/24] pack-bitmap-write: pass ownership of intermediate bitmaps
` [PATCH v3 12/24] pack-bitmap-write: fill bitmap with commit history
` [PATCH v3 13/24] bitmap: implement bitmap_is_subset()
` [PATCH v3 14/24] commit: implement commit_list_contains()
` [PATCH v3 15/24] t5310: add branch-based checks
` [PATCH v3 16/24] pack-bitmap-write: rename children to reverse_edges
` [PATCH v3 17/24] pack-bitmap.c: check reads more aggressively when loading
` [PATCH v3 18/24] pack-bitmap-write: build fewer intermediate bitmaps
` [PATCH v3 19/24] pack-bitmap-write: ignore BITMAP_FLAG_REUSE
` [PATCH v3 20/24] pack-bitmap: factor out 'bitmap_for_commit()'
` [PATCH v3 21/24] pack-bitmap: factor out 'add_commit_to_bitmap()'
` [PATCH v3 22/24] pack-bitmap-write: use existing bitmaps
` [PATCH v3 23/24] pack-bitmap-write: relax unique rewalk condition
[PATCH v2 00/14] pull: default warning improvements
2020-12-07 23:30 UTC (28+ messages)
` [PATCH v2 02/14] pull: improve default warning
` [PATCH v2 11/14] tentative: pull: change the semantics of --ff-only
` [PATCH] experiment: pull: change --ff-only and default mode
[PATCH v3 00/16] pull: default warning improvements
2020-12-07 23:08 UTC (28+ messages)
` [PATCH v3 01/16] doc: pull: explain what is a fast-forward
` [PATCH v3 02/16] pull: improve default warning
` [PATCH v3 03/16] pull: refactor fast-forward check
` [PATCH v3 04/16] pull: cleanup autostash check
` [PATCH v3 05/16] pull: trivial cleanup
` [PATCH v3 06/16] pull: move default warning
` [PATCH v3 07/16] pull: display default warning only when non-ff
` [PATCH v3 08/16] pull: trivial whitespace style fix
` [PATCH v3 09/16] pull: introduce --merge option
` [PATCH v3 10/16] pull: show warning with --ff
` [PATCH v3 11/16] rebase: add REBASE_DEFAULT
` [PATCH v3 12/16] pull: move configurations fetches
` [PATCH v3 13/16] pull: add proper error with --ff-only
` [PATCH 1/2] "
` [PATCH 2/2] tentative: pull: change the semantics of --ff-only
` [PATCH v3 14/16] test: merge-pull-config: trivial cleanup
` [PATCH v3 15/16] test: pull-options: revert unnecessary changes
` [PATCH v3 16/16] pull: trivial memory fix
[PATCH] completion: bash: fix gitk alias regression
2020-12-07 21:44 UTC (3+ messages)
BUG in fetching non-checked out submodule
2020-12-07 21:10 UTC (13+ messages)
` [PATCH] submodules: fix of regression on fetching of non-init subsub-repo
` [PATCH v2] "
[PATCH] init-db: init the_repository->hash_algo early from GIT_DEFAULT_HASH
2020-12-07 19:31 UTC (6+ messages)
`git grep` is too picky about option parsing
2020-12-07 19:35 UTC (5+ messages)
[PATCH 0/9] misc commit-graph and oid-array cleanups
2020-12-07 19:26 UTC (19+ messages)
` [PATCH 6/9] oid-array: provide a for-loop iterator
` [PATCH 7/9] commit-graph: drop count_distinct_commits() function
` [PATCH v2 0/9] misc commit-graph and oid-array cleanups
` [PATCH v2 1/9] oid-array.h: drop sha1 mention from header guard
` [PATCH v2 2/9] t0064: drop sha1 mention from filename
` [PATCH v2 3/9] t0064: make duplicate tests more robust
` [PATCH v2 4/9] cache.h: move hash/oid functions to hash.h
` [PATCH v2 5/9] oid-array: make sort function public
` [PATCH v2 6/9] oid-array: provide a for-loop iterator
` [PATCH v2 7/9] commit-graph: drop count_distinct_commits() function
` [PATCH v2 8/9] commit-graph: replace packed_oid_list with oid_array
` [PATCH v2 9/9] commit-graph: use size_t for array allocation and indexing
[PATCH v2 24/24] pack-bitmap-write: better reuse bitmaps
2020-12-07 19:20 UTC (3+ messages)
[PATCH v4 00/19] Parallel Checkout (part I)
2020-12-07 19:06 UTC (25+ messages)
` [PATCH v4 01/19] convert: make convert_attrs() and convert structs public
` [PATCH v4 02/19] convert: add [async_]convert_to_working_tree_ca() variants
` [PATCH v4 03/19] convert: add get_stream_filter_ca() variant
` [PATCH v4 04/19] convert: add conv_attrs classification
` [PATCH v4 05/19] entry: extract a header file for entry.c functions
` [PATCH v4 07/19] entry: extract cache_entry update from write_entry()
` [PATCH v4 08/19] entry: move conv_attrs lookup up to checkout_entry()
` [PATCH v4 09/19] entry: add checkout_entry_ca() which takes preloaded conv_attrs
` [PATCH v4 10/19] unpack-trees: add basic support for parallel checkout
[PATCH v2 23/24] pack-bitmap-write: relax unique rewalk condition
2020-12-07 18:48 UTC (5+ messages)
[PATCH] t5310: stop expecting the default branch name `master`
2020-12-07 18:39 UTC (3+ messages)
[PATCH v2 24/24] pack-bitmap-write: better reuse bitmaps
2020-12-07 18:26 UTC (2+ messages)
[PATCH v4 0/2] rev-parse options for absolute or relative paths
2020-12-07 17:19 UTC (8+ messages)
` [PATCH v4 1/2] abspath: add a function to resolve paths with missing components
` [PATCH v4 2/2] rev-parse: add option for absolute or relative path formatting
git confirm pls
2020-12-07 15:17 UTC
git confirm pls
2020-12-07 15:45 UTC
[PATCH] t7064: avoid relying on a specific default branch name
2020-12-07 15:19 UTC (2+ messages)
` [PATCH v2] "
[PATCH 00/15] Refactor chunk-format into an API
2020-12-07 13:43 UTC (3+ messages)
` [PATCH 14/15] commit-graph: restore duplicate chunk checks
Paid Guest Post
2020-12-07 11:20 UTC
[PATCH 00/21] trailer fixes
2020-12-07 9:17 UTC (22+ messages)
` [PATCH 0/5] pretty format %(trailers): improve machine readability
` [PATCH v2 "
` [PATCH v2 1/5] pretty format %(trailers) test: split a long line
` [PATCH v2 2/5] pretty format %(trailers) doc: avoid repetition
` [PATCH v2 3/5] pretty-format %(trailers): fix broken standalone "valueonly"
` [PATCH v2 4/5] pretty format %(trailers): add a "keyonly"
` [PATCH v2 5/5] pretty format %(trailers): add a "key_value_separator"
` [PATCH 2/5] pretty format %(trailers): avoid needless repetition
` [PATCH 3/5] pretty format %(trailers): add a "keyonly"
` [PATCH 4/5] pretty-format %(trailers): fix broken standalone "valueonly"
` [PATCH 5/5] pretty format %(trailers): add a "key_value_separator"
[PATCH v2 0/5] speed up 'make clean'
2020-12-07 7:47 UTC (2+ messages)
[PATCH v2 2/5] Documentation/Makefile: conditionally include ../GIT-VERSION-FILE
2020-12-07 7:45 UTC (3+ messages)
[PATCH v2 1/5] Documentation/Makefile: conditionally include doc.dep
2020-12-07 7:44 UTC (3+ messages)
GIT_DIR output from git worktree list
2020-12-07 7:28 UTC (4+ messages)
[PATCH v2 3/5] gitweb/Makefile: conditionally include ../GIT-VERSION-FILE
2020-12-07 3:26 UTC (2+ messages)
[PATCH] Makefile: conditionally include GIT-VERSION-FILE
2020-12-07 0:39 UTC
[PATCH v2 5/5] Makefile: don't use a versioned temp distribution directory
2020-12-07 0:36 UTC
[PATCH v2 4/5] Makefile: don't try to clean old debian build product
2020-12-07 0:35 UTC
[PATCH 00/26] git-log: implement new --diff-merge options
2020-12-06 16:39 UTC (10+ messages)
` [PATCH v1 00/27] "
[PATCH v2] builtin/bugreport.c: use thread-safe localtime_r()
2020-12-06 14:56 UTC (3+ messages)
` [PATCH v2 1/2] banned.h: mark non-reentrant gmtime, etc as banned
[PATCH] t6300: avoid using the default name of the initial branch
2020-12-06 13:15 UTC
[PATCH 0/1] git-gui: fix colored label backgrounds on Mac
2020-12-06 13:07 UTC (5+ messages)
` [PATCH 1/1] git-gui: fix colored label backgrounds when using themed widgets
[PATCH 0/7] diffcore-rename improvements
2020-12-06 3:01 UTC (9+ messages)
` [PATCH 1/7] diffcore-rename: avoid usage of global in too_many_rename_candidates()
` [PATCH 2/7] diffcore-rename: remove unnecessary if-clause
` [PATCH 3/7] diffcore-rename: rename num_create to num_targets
` [PATCH 4/7] diffcore-rename: change a few comments to use 'add' instead of 'create'
` [PATCH 5/7] diffcore-rename: reduce jumpiness in progress counters
` [PATCH 6/7] diffcore-rename: simplify and accelerate register_rename_src()
` [PATCH 7/7] Accelerate rename_dst setup
'git worktree repair' can't repair when main and linked worktrees are moved
2020-12-05 9:22 UTC (2+ messages)
[PATCH 00/17] use config-based hooks (config-based hooks part
2020-12-05 1:49 UTC (7+ messages)
` [PATCH 02/17] am: convert applypatch hooks to use config
` [PATCH 04/17] gc: use hook library for pre-auto-gc hook
` [PATCH 10/17] hook: convert 'post-rewrite' hook to config
` [PATCH 12/17] reference-transaction: look for hooks in config
` [PATCH 14/17] proc-receive: acquire hook list from hook.h
` [PATCH 17/17] run-command: stop thinking about hooks
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
Code repositories for project(s) associated with this public inbox
https://80x24.org/mirrors/git.git
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).