Hi Torsten, On Mon, 29 Aug 2022, Torsten Bögershausen wrote: > On Mon, Aug 29, 2022 at 02:04:42PM +0200, Johannes Schindelin wrote: > > > > > > The choosen solution is to split code in diff.c like this > > > > > > strbuf_addf(&out, "%-*s", len, name); > > > > > > into something like this: > > > > > > size_t num_padding_spaces = 0; > > > // [snip] > > > if (len > utf8_strwidth(name)) > > > num_padding_spaces = len - utf8_strwidth(name); > > > strbuf_addf(&out, "%s", name); > > > if (num_padding_spaces) > > > strbuf_addchars(&out, ' ', num_padding_spaces); > > > > ... this sounds like it would benefit from beinv refactored into a > > separate function, e.g. `strbuf_add_padded(buf, utf8string)`, both for > > readability as well as for self-documentation. > > Yes, but: > All (tm) strbuf() functions use an unsigned size_t, and are not > tolerant against passing 0 as "do nothing". I am missing something, as this seems not to contradict the idea of `strbuf_add_padded()`. Simply provide the desired width as a `size_t`, compare the width of the actual added string, and if it is shorter, pad with spaces. At no stage does this require a signed type, all involved values are strictly non-negative. > > > > Also, it is unclear to me why we have to evaluate `utf8_strwidth()` > > _twice_ and why we do not assign the result to a variable called `width` > > and then have a conditional like > > > > if (width < len) /* pad to `len` columns */ > > strbuf_addchars(&out, ' ' , len - width); > > > > instead. That would sound more logical to me. > > This is caused by the logic in diff.c: > /* > * Find the longest filename and max number of changes > */ > for (i = 0; (i < count) && (i < data->nr); i++) { > struct diffstat_file *file = data->files[i]; > [snip] > len = utf8_strwidth(file->print_name); > if (max_width < len) > max_width = len; > // and later > /* > * From here name_width is the width of the name area, > * and graph_width is the width of the graph area. > * max_change is used to scale graph properly. > */ > for (i = 0; i < count; i++) { > /* > * "scale" the filename > */ > // TB: Which means either shortening it with ... > // Or padding it, if needed, and here we need > // another > name_len = utf8_strwidth(name); I was referring to this part of the commit message: if (len > utf8_strwidth(name)) num_padding_spaces = len - utf8_strwidth(name); Here, we evaluate `utf8_strwidth(name)`, compare it to `len`, and if the former was smaller, we evaluate the same function call _again_. What my feedback intended to suggest was to store the result and reuse it: name_width = utf8_strwidth(name); if (name_width < len) num_padding_spaces = len - name_width; Ciao, Dscho