git@vger.kernel.org mailing list mirror (one of many)
 help / color / mirror / code / Atom feed
From: Jeff King <peff@peff.net>
To: Christian Couder <christian.couder@gmail.com>
Cc: git@vger.kernel.org, "Junio C Hamano" <gitster@pobox.com>,
	"Ævar Arnfjörð Bjarmason" <avarab@gmail.com>,
	"Jonathan Tan" <jonathantanmy@google.com>,
	"SZEDER Gábor" <szeder.dev@gmail.com>,
	"Christian Couder" <chriscool@tuxfamily.org>
Subject: [PATCH 0/17] drop non-object_id hashing
Date: Thu, 20 Jun 2019 03:39:52 -0400	[thread overview]
Message-ID: <20190620073952.GA1539@sigill.intra.peff.net> (raw)
In-Reply-To: <20190619214212.GE6571@sigill.intra.peff.net>

On Wed, Jun 19, 2019 at 05:42:12PM -0400, Jeff King wrote:

> I do think that sha1hash() will eventually go away in favor of
> oidhash(), but we can approach that separately, and convert oidmap along
> with everyone else.
> 
> It looks like we are close to being able to do that now. Grepping for
> sha1hash shows just about everybody dereferencing an oid object, except
> for the call in pack-objects.c. And skimming the callers there,
> they all appear to have an oid object, too.

Here are patches to do that. I decided not to build them on top of
yours, just to keep things simple. When merged with yours, there's no
textual conflict, but the new calls to sha1hash(key->hash) need to
become oidhash(key) instead (the compiler does catch this). It would be
easy to rebase, though.

I ended up with quite a few more patches than I thought I would need,
but I'm actually pretty pleased with the result. A lot of these are
cleanups in the packfile code that I'd been meaning to do for a while.

  [01/17]: describe: fix accidental oid/hash type-punning
  [02/17]: upload-pack: rename a "sha1" variable to "oid"

These first two are small cleanups I noticed in sites I touched later in
the series.

  [03/17]: pack-bitmap-write: convert some helpers to use object_id
  [04/17]: pack-objects: convert packlist_find() to use object_id
  [05/17]: pack-objects: convert locate_object_entry_hash() to object_id
  [06/17]: object: convert lookup_unknown_object() to use object_id
  [07/17]: object: convert lookup_object() to use object_id
  [08/17]: object: convert internal hash_obj() to object_id
  [09/17]: object: convert create_object() to use object_id

These ones are all just about passing object_id structs around more
consistently. In most cases, all of the callers of a particular function
were already passing "oid->hash", so we could just have them pass "oid"
instead.

The big one here is lookup_object(), which shockingly does not seem to
create any conflicts with pu.

  [10/17]: khash: drop broken oid_map typedef
  [11/17]: khash: rename kh_oid_t to kh_oid_set
  [12/17]: delta-islands: convert island_marks khash to use oids
  [13/17]: pack-bitmap: convert khash_sha1 maps into kh_oid_map
  [14/17]: khash: drop sha1-specific map types
  [15/17]: khash: rename oid helper functions

Some khash cleanups and prep to stop using sha1hash() there.

  [16/17]: hash.h: move object_id definition from cache.h
  [17/17]: hashmap: convert sha1hash() to oidhash()

And then finally we can rename the offending function. Ta-da. :)

 blob.c                           |  5 ++---
 builtin/describe.c               |  4 ++--
 builtin/fast-export.c            |  4 ++--
 builtin/fsck.c                   |  8 ++++----
 builtin/name-rev.c               |  3 +--
 builtin/pack-objects.c           | 21 +++++++++++----------
 builtin/prune.c                  |  2 +-
 builtin/unpack-objects.c         |  2 +-
 cache.h                          | 24 ------------------------
 commit-graph.c                   |  2 +-
 commit.c                         |  5 ++---
 decorate.c                       |  2 +-
 delta-islands.c                  | 24 ++++++++++++------------
 diffcore-rename.c                |  2 +-
 fetch-pack.c                     | 12 ++++++------
 fsck.c                           |  2 +-
 hash.h                           | 24 ++++++++++++++++++++++++
 hashmap.h                        |  8 +++++---
 http-push.c                      |  4 ++--
 khash.h                          | 22 ++++++----------------
 object.c                         | 26 +++++++++++++-------------
 object.h                         |  6 +++---
 oidset.c                         | 12 ++++++------
 oidset.h                         |  4 ++--
 pack-bitmap-write.c              | 30 +++++++++++++++---------------
 pack-bitmap.c                    | 16 ++++++++--------
 pack-bitmap.h                    |  2 +-
 pack-objects.c                   | 12 ++++++------
 pack-objects.h                   |  2 +-
 patch-ids.c                      |  2 +-
 reachable.c                      |  4 ++--
 refs.c                           |  2 +-
 t/helper/test-example-decorate.c |  6 +++---
 tag.c                            |  5 ++---
 tree.c                           |  5 ++---
 upload-pack.c                    |  8 ++++----
 walker.c                         |  2 +-
 37 files changed, 156 insertions(+), 168 deletions(-)

-Peff

  parent reply	other threads:[~2019-06-20  7:39 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-15 10:06 [PATCH v4 0/4] Test oidmap Christian Couder
2019-06-15 10:06 ` [PATCH v4 1/4] t/helper: add test-oidmap.c Christian Couder
2019-06-15 10:07 ` [PATCH v4 2/4] t: add t0016-oidmap.sh Christian Couder
2019-06-15 10:07 ` [PATCH v4 3/4] oidmap: use sha1hash() instead of static hash() function Christian Couder
2019-06-15 10:07 ` [PATCH v4 4/4] test-hashmap: remove 'hash' command Christian Couder
2019-06-19 21:42 ` [PATCH v4 0/4] Test oidmap Jeff King
2019-06-19 22:09   ` Jeff King
2019-06-19 22:25     ` Christian Couder
2019-06-20  7:39   ` Jeff King [this message]
2019-06-20  7:40     ` [PATCH 01/17] describe: fix accidental oid/hash type-punning Jeff King
2019-06-20 16:32       ` Junio C Hamano
2019-06-20 18:25         ` Jeff King
2019-06-20  7:40     ` [PATCH 02/17] upload-pack: rename a "sha1" variable to "oid" Jeff King
2019-06-20  7:40     ` [PATCH 03/17] pack-bitmap-write: convert some helpers to use object_id Jeff King
2019-06-20  7:41     ` [PATCH 04/17] pack-objects: convert packlist_find() " Jeff King
2019-06-20  7:41     ` [PATCH 05/17] pack-objects: convert locate_object_entry_hash() to object_id Jeff King
2019-06-20  7:41     ` [PATCH 06/17] object: convert lookup_unknown_object() to use object_id Jeff King
2019-06-20  7:41     ` [PATCH 07/17] object: convert lookup_object() " Jeff King
2019-06-20  7:41     ` [PATCH 08/17] object: convert internal hash_obj() to object_id Jeff King
2019-06-20  7:41     ` [PATCH 09/17] object: convert create_object() to use object_id Jeff King
2019-06-20 14:21       ` Ramsay Jones
2019-06-20 18:23         ` Jeff King
2019-06-20  7:41     ` [PATCH 10/17] khash: drop broken oid_map typedef Jeff King
2019-06-20  7:41     ` [PATCH 11/17] khash: rename kh_oid_t to kh_oid_set Jeff King
2019-06-20  7:41     ` [PATCH 12/17] delta-islands: convert island_marks khash to use oids Jeff King
2019-06-20 17:38       ` Jonathan Tan
2019-06-20 18:29         ` Jeff King
2019-06-20  7:41     ` [PATCH 13/17] pack-bitmap: convert khash_sha1 maps into kh_oid_map Jeff King
2019-06-20  7:41     ` [PATCH 14/17] khash: drop sha1-specific map types Jeff King
2019-06-20  7:41     ` [PATCH 15/17] khash: rename oid helper functions Jeff King
2019-06-20 17:44       ` Junio C Hamano
2019-06-20 18:27         ` Jeff King
2019-06-23 16:00           ` René Scharfe
2019-06-23 22:46             ` Jeff King
2019-06-20  7:41     ` [PATCH 16/17] hash.h: move object_id definition from cache.h Jeff King
2019-06-20 17:41       ` Junio C Hamano
2019-06-20  7:41     ` [PATCH 17/17] hashmap: convert sha1hash() to oidhash() Jeff King

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: http://vger.kernel.org/majordomo-info.html

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190620073952.GA1539@sigill.intra.peff.net \
    --to=peff@peff.net \
    --cc=avarab@gmail.com \
    --cc=chriscool@tuxfamily.org \
    --cc=christian.couder@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=jonathantanmy@google.com \
    --cc=szeder.dev@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).