On Thu, Jan 03, 2019 at 06:18:55PM -0800, Jonathan Nieder wrote: > I may be a minority in this opinion, but I had trouble understanding > what --literally would do from its name. I suspect we can come up > with a better name. > > Unfortunately, I'm terrible at coming up with names. :-P > > --dereference would be a good name when it comes to symlinks, but > it's not a good name for reading what is on the other side of a pipe. > On the plus side, it matches "diff" and "cp"'s name for the "follow > symbolic links" option. > > --plain captures the desire a little better --- we want a plain > read(2) from the file instead of trying to be smart and look at > whether it is e.g. a block device. But in the context of "diff", that > would seem more like an option that affects the output. > > What would you think of > > - always reading from fifos instead of describing them, since I've > never encountered a use case where people want the latter > > - --dereference to control whether to follow symlinks This is actually surprisingly difficult. The reason I implemented this only for no-index mode is because there are actually several places we can stat a file in the diff code, and implementing a --dereference option that catches all of those cases and getting the option passed down to them is non-trivial. Since my primary environment is on Linux, I need to implement functional --dereference semantics before implementing the FIFO functionality to know if it works in my use case. I agree that would be a nicer approach overall, so let me see if I can take another stab at it in a way that isn't excessively complex. It would also make the name less controversial, since "--dereference" is the obvious choice for dereferencing symlinks. > [...] > > --- a/diff-no-index.c > > +++ b/diff-no-index.c > > @@ -75,7 +75,25 @@ static int populate_from_stdin(struct diff_filespec *s) > > return 0; > > } > > > > -static struct diff_filespec *noindex_filespec(const char *name, int mode) > > +static int populate_literally(struct diff_filespec *s) > > +{ > > + struct strbuf buf = STRBUF_INIT; > > + size_t size = 0; > > + int fd = xopen(s->path, O_RDONLY); > > + > > + if (strbuf_read(&buf, fd, 0) < 0) > > + return error_errno("error while reading from '%s'", s->path); > > + > > + s->should_munmap = 0; > > + s->data = strbuf_detach(&buf, &size); > > + s->size = size; > > + s->should_free = 1; > > + s->read_literally = 1; > > Oh! --read-literally works perfectly for me as a name. :) If I can't manage to split this out into two pieces, I'll pick that as the name for the reroll. -- brian m. carlson: Houston, Texas, US OpenPGP: https://keybase.io/bk2204