git@vger.kernel.org mailing list mirror (one of many)
 help / color / mirror / code / Atom feed
* [PATCH] test_must_be_empty: simplify file existence check
@ 2018-03-26 11:58 SZEDER Gábor
  2018-03-26 12:48 ` Jeff King
  0 siblings, 1 reply; 6+ messages in thread
From: SZEDER Gábor @ 2018-03-26 11:58 UTC (permalink / raw)
  To: Junio C Hamano; +Cc: git, SZEDER Gábor

Commit ea3c87d0b7 (test_must_be_empty: make sure the file exists, not
just empty, 2018-02-27) basically duplicated the 'test_path_is_file'
helper function in 'test_must_be_empty'.

Just call 'test_path_is_file' to avoid this code duplication.

Signed-off-by: SZEDER Gábor <szeder.dev@gmail.com>
---
 t/test-lib-functions.sh | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
index d2eaf5ab67..36ad8accdd 100644
--- a/t/test-lib-functions.sh
+++ b/t/test-lib-functions.sh
@@ -718,11 +718,8 @@ verbose () {
 # otherwise.
 
 test_must_be_empty () {
-	if ! test -f "$1"
-	then
-		echo "'$1' is missing"
-		return 1
-	elif test -s "$1"
+	test_path_is_file "$1" &&
+	if test -s "$1"
 	then
 		echo "'$1' is not empty, it contains:"
 		cat "$1"
-- 
2.17.0.rc1.145.gfac1bf9500


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] test_must_be_empty: simplify file existence check
  2018-03-26 11:58 [PATCH] test_must_be_empty: simplify file existence check SZEDER Gábor
@ 2018-03-26 12:48 ` Jeff King
  2018-03-26 13:09   ` SZEDER Gábor
  2018-03-26 13:11   ` [PATCH v2] " SZEDER Gábor
  0 siblings, 2 replies; 6+ messages in thread
From: Jeff King @ 2018-03-26 12:48 UTC (permalink / raw)
  To: SZEDER Gábor; +Cc: Junio C Hamano, git

On Mon, Mar 26, 2018 at 01:58:15PM +0200, SZEDER Gábor wrote:

> Commit ea3c87d0b7 (test_must_be_empty: make sure the file exists, not
> just empty, 2018-02-27) basically duplicated the 'test_path_is_file'
> helper function in 'test_must_be_empty'.
> 
> Just call 'test_path_is_file' to avoid this code duplication.

This looks like an improvement to me.

I think you meant to reference 11395a3b4b16d9fc637ca2e41a6892ea2e6289ce,
though (I don't have ea3c87d0b7 at all).

-Peff

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] test_must_be_empty: simplify file existence check
  2018-03-26 12:48 ` Jeff King
@ 2018-03-26 13:09   ` SZEDER Gábor
  2018-03-26 13:11   ` [PATCH v2] " SZEDER Gábor
  1 sibling, 0 replies; 6+ messages in thread
From: SZEDER Gábor @ 2018-03-26 13:09 UTC (permalink / raw)
  To: Jeff King; +Cc: Junio C Hamano, Git mailing list

On Mon, Mar 26, 2018 at 2:48 PM, Jeff King <peff@peff.net> wrote:
> On Mon, Mar 26, 2018 at 01:58:15PM +0200, SZEDER Gábor wrote:
>
>> Commit ea3c87d0b7 (test_must_be_empty: make sure the file exists, not
>> just empty, 2018-02-27) basically duplicated the 'test_path_is_file'
>> helper function in 'test_must_be_empty'.
>>
>> Just call 'test_path_is_file' to avoid this code duplication.
>
> This looks like an improvement to me.
>
> I think you meant to reference 11395a3b4b16d9fc637ca2e41a6892ea2e6289ce,
> though (I don't have ea3c87d0b7 at all).

Indeed.  I remember picking up that patch from the mailing list, which
then became ea3c87d0b7 in my repo.  What I don't remember is how I
managed to build on top of this hand-picked commit instead of what has
been in git.git for a month...

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH v2] test_must_be_empty: simplify file existence check
  2018-03-26 12:48 ` Jeff King
  2018-03-26 13:09   ` SZEDER Gábor
@ 2018-03-26 13:11   ` SZEDER Gábor
  2018-03-28  0:10     ` Junio C Hamano
  1 sibling, 1 reply; 6+ messages in thread
From: SZEDER Gábor @ 2018-03-26 13:11 UTC (permalink / raw)
  To: Junio C Hamano; +Cc: Jeff King, git, SZEDER Gábor

Commit 11395a3b4b (test_must_be_empty: make sure the file exists, not
just empty, 2018-02-27) basically duplicated the 'test_path_is_file'
helper function in 'test_must_be_empty'.

Just call 'test_path_is_file' to avoid this code duplication.

Signed-off-by: SZEDER Gábor <szeder.dev@gmail.com>
---

The only change is to refer to the right commit in the log message.

 t/test-lib-functions.sh | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
index d2eaf5ab67..36ad8accdd 100644
--- a/t/test-lib-functions.sh
+++ b/t/test-lib-functions.sh
@@ -718,11 +718,8 @@ verbose () {
 # otherwise.
 
 test_must_be_empty () {
-	if ! test -f "$1"
-	then
-		echo "'$1' is missing"
-		return 1
-	elif test -s "$1"
+	test_path_is_file "$1" &&
+	if test -s "$1"
 	then
 		echo "'$1' is not empty, it contains:"
 		cat "$1"
-- 
2.17.0.rc1.148.gc92dc354c5


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH v2] test_must_be_empty: simplify file existence check
  2018-03-26 13:11   ` [PATCH v2] " SZEDER Gábor
@ 2018-03-28  0:10     ` Junio C Hamano
  2018-03-28  5:20       ` Junio C Hamano
  0 siblings, 1 reply; 6+ messages in thread
From: Junio C Hamano @ 2018-03-28  0:10 UTC (permalink / raw)
  To: SZEDER Gábor; +Cc: Jeff King, git

SZEDER Gábor <szeder.dev@gmail.com> writes:

> Commit 11395a3b4b (test_must_be_empty: make sure the file exists, not
> just empty, 2018-02-27) basically duplicated the 'test_path_is_file'
> helper function in 'test_must_be_empty'.
>
> Just call 'test_path_is_file' to avoid this code duplication.
>
> Signed-off-by: SZEDER Gábor <szeder.dev@gmail.com>
> ---
>
> The only change is to refer to the right commit in the log message.
>
>  t/test-lib-functions.sh | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
> index d2eaf5ab67..36ad8accdd 100644
> --- a/t/test-lib-functions.sh
> +++ b/t/test-lib-functions.sh
> @@ -718,11 +718,8 @@ verbose () {
>  # otherwise.
>  
>  test_must_be_empty () {
> -	if ! test -f "$1"
> -	then
> -		echo "'$1' is missing"
> -		return 1
> -	elif test -s "$1"
> +	test_path_is_file "$1" &&
> +	if test -s "$1"
>  	then
>  		echo "'$1' is not empty, it contains:"
>  		cat "$1"

"Just call it" is fine as an idea but

	A &&
	if B
	then
		...
	fi

is somewhat questionable.  Shouldn't we make it

	if A && B
	then
		...
	fi

instead?  That way, if we ever need to add an else clause, the logic
flow would be more obvious, no?


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH v2] test_must_be_empty: simplify file existence check
  2018-03-28  0:10     ` Junio C Hamano
@ 2018-03-28  5:20       ` Junio C Hamano
  0 siblings, 0 replies; 6+ messages in thread
From: Junio C Hamano @ 2018-03-28  5:20 UTC (permalink / raw)
  To: SZEDER Gábor; +Cc: Jeff King, git

Junio C Hamano <gitster@pobox.com> writes:

>>  test_must_be_empty () {
>> -	if ! test -f "$1"
>> -	then
>> -		echo "'$1' is missing"
>> -		return 1
>> -	elif test -s "$1"
>> +	test_path_is_file "$1" &&
>> +	if test -s "$1"
>>  	then
>>  		echo "'$1' is not empty, it contains:"
>>  		cat "$1"
>
> "Just call it" is fine as an idea but
>
> 	A &&
> 	if B
> 	then
> 		...
> 	fi
>
> is somewhat questionable.  Shouldn't we make it
>
> 	if A && B
> 	then
> 		...
> 	fi
>
> instead?

Nah, you want to treat A's success as a condition *not* to enter the
"then" clause in this case, so my rewrite is bogus.  SOrry for the
noise.




^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2018-03-28  5:20 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-03-26 11:58 [PATCH] test_must_be_empty: simplify file existence check SZEDER Gábor
2018-03-26 12:48 ` Jeff King
2018-03-26 13:09   ` SZEDER Gábor
2018-03-26 13:11   ` [PATCH v2] " SZEDER Gábor
2018-03-28  0:10     ` Junio C Hamano
2018-03-28  5:20       ` Junio C Hamano

Code repositories for project(s) associated with this public inbox

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).