git@vger.kernel.org mailing list mirror (one of many)
 help / color / mirror / code / Atom feed
From: Jonathan Nieder <jrnieder@gmail.com>
To: Stefan Beller <sbeller@google.com>
Cc: gitster@pobox.com, git@vger.kernel.org, Jens.Lehmann@web.de,
	peff@peff.net, sunshine@sunshineco.com
Subject: Re: [PATCHv14 5/7] git submodule update: have a dedicated helper for cloning
Date: Fri, 19 Feb 2016 15:07:40 -0800	[thread overview]
Message-ID: <20160219230740.GM28749@google.com> (raw)
In-Reply-To: <1455905833-7449-6-git-send-email-sbeller@google.com>

Hi,

Stefan Beller wrote:

> This introduces a new helper function in git submodule--helper
> which takes care of cloning all submodules, which we want to
> parallelize eventually.

Patches 1-4 are still
Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>

I still have trouble reading this patch (patch 5).  Some musing below
to figure out what could change to make it more readable (perhaps in a
patch on top).

[...]
> --- a/builtin/submodule--helper.c
> +++ b/builtin/submodule--helper.c
> @@ -255,6 +255,234 @@ static int module_clone(int argc, const char **argv, const char *prefix)
>  	return 0;
>  }
>  
> +struct submodule_update_clone {
> +	/* states */
> +	int count;
> +	int print_unmatched;
> +	/* configuration */
> +	int quiet;
> +	const char *reference;
> +	const char *depth;
> +	const char *recursive_prefix;
> +	const char *prefix;
> +	struct module_list list;
> +	struct string_list projectlines;
> +	struct submodule_update_strategy update;
> +	struct pathspec pathspec;
> +};
> +#define SUBMODULE_UPDATE_CLONE_INIT {0, 0, 0, NULL, NULL, NULL, NULL, MODULE_LIST_INIT, STRING_LIST_INIT_DUP, SUBMODULE_UPDATE_STRATEGY_INIT}

I think these struct fields need some comments.  It's not clear what
most of them represent.

[...]
> +static int update_clone_inspect_next_task(struct child_process *cp,

What is being inspected here?  What does the return value represent?

Would a name like 'prepare_to_clone_next_submodule' make sense?  A
comment could say that 'ce' points to the candidate submodule to clone,
that the return value represents whether we want to clone it, and
that the first parameter is an output parameter representing a command
to run to carry out the clone.

[...]
> +	if (ce_stage(ce)) {
> +		if (pp->recursive_prefix)
> +			strbuf_addf(err, "Skipping unmerged submodule %s/%s\n",
> +				    pp->recursive_prefix, ce->name);
> +		else
> +			strbuf_addf(err, "Skipping unmerged submodule %s\n",
> +				    ce->name);

Nit: this would be easier to scan with braces.

[...]
> +	sub = submodule_from_path(null_sha1, ce->name);

It's common to call submodule_from_path with null_sha1 as a parameter
but I have trouble continuing to remember what that means.  Maybe
there should be a separate function that handles that?  As a
side-effect, the name and docstring of that function could explain
what it means, which I still am not sure about. :)


> +	if (pp->recursive_prefix)
> +		displaypath = relative_path(pp->recursive_prefix,
> +					    ce->name, &displaypath_sb);

Nit: could use braces.

> +	else
> +		displaypath = ce->name;
> +
> +	if (pp->update.type == SM_UPDATE_NONE ||
> +	    (pp->update.type == SM_UPDATE_UNSPECIFIED &&
> +	     sub->update_strategy.type == SM_UPDATE_NONE)) {

Nit: this might be more readable with the operators starting each
line:

	if (pp->update.type == SM_UPDATE_NONE
	    || (pp->update.type == SM_UPDATE_UNSPECIFIED
	        && sub->update_strategy.type == SM_UPDATE_NONE)) {

What does pp stand for?

Is the --update parameter ever set to 'none'?  What does it mean
when someone sets it to none?

> +		strbuf_addf(err, "Skipping submodule '%s'\n",
> +			    displaypath);

Does the caller expect a newline at the end of err?

In the refs code that uses an err strbuf, the convention is to
not end the message with a newline.  That way, a function like
die() can insert a newline and messages are guaranteed to be
newline-terminated even if someone is sloppy and does the wrong thing
when generating an error.

[...]
> +	if (needs_cloning) {

Could de-indent:

	if (!needs_cloning)
		goto cleanup;

> +		cp->git_cmd = 1;
> +		cp->no_stdin = 1;
> +		cp->stdout_to_stderr = 1;
> +		cp->err = -1;
> +		argv_array_push(&cp->args, "submodule--helper");
> +		argv_array_push(&cp->args, "clone");
> +		if (pp->quiet)
> +			argv_array_push(&cp->args, "--quiet");
> +
> +		if (pp->prefix)
> +			argv_array_pushl(&cp->args, "--prefix", pp->prefix, NULL);
> +

Odd whitespace.  I think it would be fine to remove the blank lines.

> +		argv_array_pushl(&cp->args, "--path", sub->path, NULL);
> +		argv_array_pushl(&cp->args, "--name", sub->name, NULL);
> +		argv_array_pushl(&cp->args, "--url", url, NULL);
> +		if (pp->reference)
> +			argv_array_push(&cp->args, pp->reference);
> +		if (pp->depth)
> +			argv_array_push(&cp->args, pp->depth);

What does 'cp' stand for mean?  Would a name like 'child' work?

[...]
> +static int update_clone_get_next_task(struct child_process *cp,
> +				      struct strbuf *err,
> +				      void *pp_cb,
> +				      void **pp_task_cb)
> +{
> +	struct submodule_update_clone *pp = pp_cb;
> +
> +	for (; pp->count < pp->list.nr; pp->count++) {
> +		const struct cache_entry *ce = pp->list.entries[pp->count];
> +		if (update_clone_inspect_next_task(cp, err, pp,
> +						   pp_task_cb, ce)) {
> +			pp->count++;
> +			return 1;
> +		}
> +	}
> +	return 0;
> +}

Ah, that clarifies things a bit.

The 'count' variable is more of a cursor than a count.  Would a name +
comment like

	/* index into 'list' representing the next submodule to consider cloning */
	int current;

work?

> +
> +static int update_clone_start_failure(struct child_process *cp,
> +				      struct strbuf *err,
> +				      void *pp_cb,
> +				      void *pp_task_cb)
> +{
> +	struct submodule_update_clone *pp = pp_cb;
> +
> +	strbuf_addf(err, "error when starting a child process");
> +	pp->print_unmatched = 1;

What does print_unmatched mean?

[...]
> +static int update_clone_task_finished(int result,
> +				      struct child_process *cp,
> +				      struct strbuf *err,
> +				      void *pp_cb,
> +				      void *pp_task_cb)
> +{
> +	struct submodule_update_clone *pp = pp_cb;
> +
> +	if (!result) {
> +		return 0;
> +	} else {

No need for an 'else' here --- the 'if' already returned.

> +		strbuf_addf(err, "error in one child process");
> +		pp->print_unmatched = 1;

What does print_unmatched mean?

[...]
> +static int update_clone(int argc, const char **argv, const char *prefix)
> +{
> +	const char *update = NULL;
> +	struct string_list_item *item;
> +	struct submodule_update_clone pp = SUBMODULE_UPDATE_CLONE_INIT;
> +
> +	struct option module_list_options[] = {

The name looks stale.

> +		OPT_STRING(0, "prefix", &prefix,
> +			   N_("path"),
> +			   N_("path into the working tree")),
> +		OPT_STRING(0, "recursive_prefix", &pp.recursive_prefix,
> +			   N_("path"),
> +			   N_("path into the working tree, across nested "
> +			      "submodule boundaries")),

What do these options represent?  I'm used to the 'prefix' parameter to
a command coming from git machinery that remembers what the path to the
original cwd was relative to the worktree or repository root.  Here
there's an option to set it --- is that intentional?  Would setting the
environment variable GIT_PREFIX (that git already knows how to respect)
work in its place?

What is recursive_prefix relative to?

Nit: it would be more idiomatic to use a dash in place of an underscore
in the second one's name.  But this is an internal interface so it
doesn't matter much.

> +		OPT_STRING(0, "update", &update,
> +			   N_("string"),
> +			   N_("update command for submodules")),

This one is confusing to me because while the script supports --rebase /
--merge / --checkout this option seems to be more general.

If the help string said '(rebase, merge, or checkout)' then I wouldn't
mind.

> +		OPT_STRING(0, "reference", &pp.reference, "<repository>",
> +			   N_("Use the local reference repository "
> +			      "instead of a full clone")),

Is this allowed to be relative?  If so, what is it relative to?

[...]
> +		OPT__QUIET(&pp.quiet, N_("do't print cloning progress")),

Typo.

[...]
> +	const char *const git_submodule_helper_usage[] = {
> +		N_("git submodule--helper list [--prefix=<path>] [<path>...]"),

Is this the 'list' subcommand?

[...]
> +	gitmodules_config();
> +	/* Overlay the parsed .gitmodules file with .git/config */
> +	git_config(submodule_config, NULL);
> +	run_processes_parallel(1, update_clone_get_next_task,
> +				  update_clone_start_failure,
> +				  update_clone_task_finished,
> +				  &pp);

Neat. \o/

> +	if (pp.print_unmatched) {
> +		printf("#unmatched\n");

I'm still confused about this.  I think a comment where
'print_unmatched' is declared would probably clear it up.

[...]
> +	for_each_string_list_item(item, &pp.projectlines)
> +		utf8_fprintf(stdout, "%s", item->string);

(just curious) why are these saved up and printed all at once instead
of being printed as it goes?

[...]
> --- a/git-submodule.sh
> +++ b/git-submodule.sh

Very nice.

Thanks,
Jonathan

  reply	other threads:[~2016-02-19 23:08 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-02-19 18:17 [PATCHv14 0/7] Expose submodule parallelism to the user Stefan Beller
2016-02-19 18:17 ` [PATCHv14 1/7] submodule-config: keep update strategy around Stefan Beller
2016-02-19 18:17 ` [PATCHv14 2/7] submodule-config: drop check against NULL Stefan Beller
2016-02-19 18:17 ` [PATCHv14 3/7] fetching submodules: respect `submodule.fetchJobs` config option Stefan Beller
2016-02-19 18:17 ` [PATCHv14 4/7] submodule update: direct error message to stderr Stefan Beller
2016-02-19 18:17 ` [PATCHv14 5/7] git submodule update: have a dedicated helper for cloning Stefan Beller
2016-02-19 23:07   ` Jonathan Nieder [this message]
2016-02-19 23:49     ` Stefan Beller
2016-02-20  0:32       ` Jonathan Nieder
2016-02-19 18:17 ` [PATCHv14 6/7] submodule update: expose parallelism to the user Stefan Beller
2016-02-19 18:17 ` [PATCHv14 7/7] clone: allow an explicit argument for parallel submodule clones Stefan Beller
2016-02-19 21:04 ` [PATCHv14 0/7] Expose submodule parallelism to the user Junio C Hamano
2016-02-23 23:33   ` Junio C Hamano
2016-02-23 23:42     ` Stefan Beller
2016-02-23 23:44       ` Junio C Hamano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: http://vger.kernel.org/majordomo-info.html

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160219230740.GM28749@google.com \
    --to=jrnieder@gmail.com \
    --cc=Jens.Lehmann@web.de \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=peff@peff.net \
    --cc=sbeller@google.com \
    --cc=sunshine@sunshineco.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).