about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index e9e4e2ab..b8c05cf7 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -167,13 +167,14 @@ changed = \$(shell git ls-files -m)
 dsyn :: \$(addsuffix .syntax, \$(filter \$(changed), \$(syn_files)))
 
 check-manifest :: MANIFEST
-        if git ls-files >\$?.gen 2>&1; then diff -u \$? \$?.gen; fi
+        if test -e .git && git ls-files >\$?.gen 2>&1; then \\
+                diff -u \$? \$?.gen; fi
 
 # the traditional way running per-*.t processes:
 check-each :: pure_all check-manifest
         \$(EATMYDATA) \$(PROVE) --state=save -bvw -j\$(N)
 
-# lightly-tested way to runn tests, relies "--state=save" in check-each
+# lightly-tested way to run tests, relies "--state=save" in check-each
 # for best performance
 check-run :: pure_all check-manifest
         \$(EATMYDATA) \$(PROVE) -bvw t/run.perl :: -j\$(N)