about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2019-06-13 02:26:30 +0000
committerEric Wong <e@80x24.org>2019-06-13 02:27:21 +0000
commitf4dbd80157bd785cf5d863d517b7334bd2795bab (patch)
tree1211480d695e54b177709c5963d95a84b801033d /Makefile.PL
parentac8fb90b7a20e790fc5e927ffd8134b6a5c2661c (diff)
downloadpublic-inbox-f4dbd80157bd785cf5d863d517b7334bd2795bab.tar.gz
Digest::SHA is the most notable missing package at runtime
for a minimal system.

Tests don't run at all without Test::Simple (or Test::More).
Plack::Test is also a separate package, too...

Also, the package for IO::Compress::Gzip should be IO::Compress;
as perl-PerlIO-gzip is a different thing entirely which is not
relevant to our needs.

Test::HTTP::Server::Simple doesn't seem required at all for Plack
tests.

ExtUtils::MakeMaker needs to be documented as a install dependency
for people installing this, too; since AFAIK public-inbox is not
yet in any distros.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index b1274ad1..341d42af 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -28,6 +28,11 @@ WriteMakefile(
                 # We also depend on git.
                 # Keep this sorted and synced to the INSTALL document
                 'Date::Parse' => 0,
+
+                # libperl$PERL_VERSION,
+                # `perl5' on FreeBSD
+                # perl-Digest-SHA on RH-based
+                'Digest::SHA' => 0,
                 'Email::MIME' => 0,
 
                 # the following should be pulled in by Email::MIME:
@@ -44,6 +49,14 @@ WriteMakefile(
 
                 # We have more test dependencies, but do not force
                 # users to install them.  See INSTALL
+
+                # All Perl installs I know about have these, but RH-based
+                # distros make them separate even though 'perl' pulls them in
+                'File::Path' => 0,
+                'File::Temp' => 0,
+                'Getopt::Long' => 0,
+                'Exporter' => 0,
+                # ExtUtils::MakeMaker # this file won't run w/o it...
         },
         MAN3PODS => \%man3,
 );