about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-01-24 22:09:30 +0000
committerEric Wong <e@yhbt.net>2020-01-25 09:00:50 +0000
commitd62d98b9a7f502da65673f0b83a6d06312c060d9 (patch)
tree352ed211a55cd376691c4698bbf73a59f95d0e0d /Makefile.PL
parent4d19d3a79188591a25d325128d2ed0a153766577 (diff)
downloadpublic-inbox-d62d98b9a7f502da65673f0b83a6d06312c060d9.tar.gz
I noticed the TODO was out-of-date on the website, among some
other things.  This was broken in moving GNU-isms in the
Makefile to Perl.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 2b3c7fd0..46ef99f9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -13,9 +13,10 @@ $v->{news_deps} = [ map { "Documentation/RelNotes/$_.eml" } @RELEASES ];
 $v->{txt} = [ qw(INSTALL README COPYING TODO HACKING) ];
 my @dtxt = grep(m!\ADocumentation/.*\.txt\z!, @manifest);
 push @dtxt, 'Documentation/standards.txt';
+push @dtxt, @{$v->{txt}};
 for my $txt (@dtxt) {
         my $html = $txt;
-        $html =~ s/\.txt\z/.html/;
+        $html =~ s/\.txt\z/.html/ or $html .= '.html';
         $t->{"$html : $txt"} = [ "\$(txt2pre) <$txt" ];
 }
 $v->{t_slash_star_dot_t} = [ grep(m!\At/.*\.t\z!, @manifest) ];