about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-02-05 22:03:47 -0600
committerEric Wong <e@yhbt.net>2020-02-06 19:10:56 +0000
commit8e15cbdbe35671c7e3c10573638ed4dcc7ce7a4f (patch)
tree7d5f5064e5428bd506be601d16899c276cca4ff3 /Makefile.PL
parent6864cdba2bb65069d15d26e0b9af6ade8edd0ec3 (diff)
downloadpublic-inbox-8e15cbdbe35671c7e3c10573638ed4dcc7ce7a4f.tar.gz
There's no need to keep Xapian manpage renderings in a separate
subdirectory, after all.

Eliminating this difference between the local FS and URL path
will allow relative URLs to the Xapian manpages in our local
HTML documentation to work smoothly, since there was never any
".x/" path component for files served from public-inbox.org
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 59874170..8f1bc4b4 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -71,10 +71,10 @@ $v->{rsync_docs} = [ @{$v->{gz_docs}}, @{$v->{docs}},
 # external manpages which we host ourselves, since some packages
 # (currently just Xapian) doesn't host manpages themselves.
 my @xman = qw(copydatabase.1 xapian-compact.1);
-$v->{xdocs} = [ map { "Documentation/.x/.$_.txt" } @xman ];
-$v->{xdocs_html} = [ map { "Documentation/.x/.$_.html" } @xman ];
+$v->{xdocs} = [ map { "Documentation/.$_.txt" } @xman ];
+$v->{xdocs_html} = [ map { "Documentation/.$_.html" } @xman ];
 for (@{$v->{xdocs}}) {
-        $t->{"$_ : | Documentation/.x"} = [
+        $t->{"$_:"} = [
                 '$(PERL) -w Documentation/extman.perl $@ >$@+',
                 'mv $@+ $@'
         ];