about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@yhbt.net>2020-01-24 22:09:29 +0000
committerEric Wong <e@yhbt.net>2020-01-25 09:00:48 +0000
commit4d19d3a79188591a25d325128d2ed0a153766577 (patch)
tree628549bc3aaa50e7eb42141690ee2e45b137a6c1 /Makefile.PL
parent0cf1c8b305e15d9ca9869c624a71c96b96a7a5cc (diff)
downloadpublic-inbox-4d19d3a79188591a25d325128d2ed0a153766577.tar.gz
Repeatedly rebuilding `NEWS' because the mtime of `NEWS'
is synched to the latest release .eml is a bit annoying,
but necessary to save bandwidth for the website.

So we'll also update the mtime of the source .eml file when
reading them.  It's kinda gross to be setting mtimes of source
.eml files in Documentation/RelNotes/, but I can't think of
anything better at the moment...
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 94ec16c6..2b3c7fd0 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -8,6 +8,8 @@ chomp(my @manifest = (<$m>));
 my @EXE_FILES = grep(m!^script/!, @manifest);
 my $v = {};
 my $t = {};
+my @RELEASES = qw(v1.2.0 v1.1.0-pre1 v1.0.0); # do not sort
+$v->{news_deps} = [ map { "Documentation/RelNotes/$_.eml" } @RELEASES ];
 $v->{txt} = [ qw(INSTALL README COPYING TODO HACKING) ];
 my @dtxt = grep(m!\ADocumentation/.*\.txt\z!, @manifest);
 push @dtxt, 'Documentation/standards.txt';
@@ -91,6 +93,7 @@ my $VARS = join("\n", map {;
         my $varname = $_;
         join('', map { "$varname += $_\n" } sort @{$v->{$varname}});
 } grep(!/^-/, sort keys %$v));
+$VARS .= "\nRELEASES = ".join(' ', @RELEASES)."\n";
 
 # Don't waste user's disk space by installing some pods from
 # imported code or internal use only