about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2016-06-20 00:57:11 +0000
committerEric Wong <e@80x24.org>2016-06-20 00:57:33 +0000
commit4b9ab5255a2ce9e0f75a80afc731a96b760e9816 (patch)
treed0a843de73cd0cd5c8ebd883d14e6ed6befab595 /Makefile.PL
parentf8d7edb01ddf5fd2bfef08f72ec3c5cfb4ffa937 (diff)
downloadpublic-inbox-4b9ab5255a2ce9e0f75a80afc731a96b760e9816.tar.gz
And add a check-manifest target to the Makefile to
ensure we're up-to-date with git (but do not depend on
git).
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 171712a7..4a911037 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,7 +47,10 @@ my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES) \$(SCRIPTS))
 
 syntax:: \$(my_syntax)
 
-check:: pure_all
+check-manifest :: MANIFEST
+        if git ls-files >\$<.gen 2>&1; then diff -u \$< \$<.gen; fi
+
+check:: pure_all check-manifest
         \$(EATMYDATA) prove -lv -j\$(N)
 
 EOF