about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2016-05-14 01:16:15 +0000
committerEric Wong <e@80x24.org>2016-05-14 01:17:17 +0000
commit47f28a70bf3c56f441ca5315fdd5c2e84f4d5c57 (patch)
tree7f5feb8d89c8c8643467f66447855233fc796996 /Makefile.PL
parent821dcde53cc4ea636078b282c1d81a30f7070a96 (diff)
downloadpublic-inbox-47f28a70bf3c56f441ca5315fdd5c2e84f4d5c57.tar.gz
This should help poor developers who still use rotating disks on
cheap netbooks.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 1948848f..448c79c3 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -36,6 +36,10 @@ WriteMakefile(
 
 sub MY::postamble {
   <<EOF;
+# support using eatmydata to speed up tests (apt-get install eatmydata):
+# https://www.flamingspork.com/projects/libeatmydata/
+EATMYDATA =
+-include config.mak
 -include Documentation/include.mk
 my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES))
 
@@ -47,7 +51,7 @@ N := \$(shell echo \$\$(( \$\$(nproc 2>/dev/null || echo 2) + 1)))
 syntax:: \$(my_syntax)
 
 check:: pure_all
-        prove -lv -j\$(N)
+        \$(EATMYDATA) prove -lv -j\$(N)
 
 EOF
 }