about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2016-05-28 01:57:10 +0000
committerEric Wong <e@80x24.org>2016-05-28 01:57:36 +0000
commit0c9bc00d62e027ebee873f51d51e3dd0832e6e41 (patch)
treead26176964e724c6ea8370677a1bf220c73e804e /Makefile.PL
parent17577bf82166f4967bb66cb120fc42ce5448fe54 (diff)
downloadpublic-inbox-0c9bc00d62e027ebee873f51d51e3dd0832e6e41.tar.gz
Relying on the number of processors isn't a great idea
since some of our tests rely on delays to test blocking
and slow client behavior.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3cffe133..61cb77b6 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -40,10 +40,10 @@ sub MY::postamble {
 EATMYDATA =
 -include config.mak
 -include Documentation/include.mk
+N ?= \$(shell echo \$\$(( \$\$(nproc 2>/dev/null || echo 2) + 1)))
 SCRIPTS := scripts/ssoma-replay
 my_syntax := \$(addsuffix .syntax, $PM_FILES \$(EXE_FILES) \$(SCRIPTS))
 
-N := \$(shell echo \$\$(( \$\$(nproc 2>/dev/null || echo 2) + 1)))
 
 %.syntax ::
         @\$(PERL) -I lib -c \$(subst .syntax,,\$@)