about summary refs log tree commit homepage
path: root/Makefile.PL
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2014-04-19 19:19:06 +0000
committerEric Wong <e@80x24.org>2014-04-19 23:10:12 +0000
commit6a414a4087a59ad8c62cbef30984632ea31ced23 (patch)
tree113e0937e35f110496027a95415fc346f7f532d5 /Makefile.PL
parent6dfb9311700d09fb019bee74d2b420c6cdea8b8f (diff)
downloadpublic-inbox-6a414a4087a59ad8c62cbef30984632ea31ced23.tar.gz
We have an HTML homepage, OMG!
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 1 insertions, 14 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 245bb887..3dfafe7b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -33,20 +33,7 @@ WriteMakefile(
 
 sub MY::postamble {
   <<'EOF';
-RSYNC_DEST = public-inbox.org:/srv/public-inbox/
-docs = README COPYING INSTALL $(shell git ls-files Documentation/ '*.txt')
-gz_docs = $(addsuffix .gz, $(docs))
-%.gz: %
-        gzip -9 --rsyncable < $< > $@+
-        touch -r $< $@+
-        mv $@+ $@
-
-gz-docs: $(gz_docs)
-rsync-docs:
-        git set-file-times $(docs)
-        $(MAKE) gz-docs
-        rsync --chmod=Fugo=r -av $(gz_docs) $(docs) $(RSYNC_DEST)
-
+-include Documentation/include.mk
 N = $(shell echo $$(( $$(nproc 2>/dev/null || echo 2) + 1)))
 check:: pure_all
         prove -lv -j$(N)