git@vger.kernel.org mailing list mirror (one of many)
 help / color / mirror / code / Atom feed
From: Lars Schneider <larsxschneider@gmail.com>
To: Ben Peart <peartben@gmail.com>
Cc: git@vger.kernel.org, gitster@pobox.com, benpeart@microsoft.com,
	christian.couder@gmail.com
Subject: Re: [PATCH v5 5/8] convert: Update generic functions to only use generic data structures
Date: Mon, 10 Apr 2017 14:05:52 +0200	[thread overview]
Message-ID: <5900F7F1-89D9-433E-A6C3-0AB27C815BE6@gmail.com> (raw)
In-Reply-To: <20170407120354.17736-6-benpeart@microsoft.com>


> On 07 Apr 2017, at 14:03, Ben Peart <peartben@gmail.com> wrote:
> 
> Update all functions that are going to be moved into a reusable module
> so that they only work with the reusable data structures.  Move code
> that is specific to the filter out into the filter specific functions.
> 
> Signed-off-by: Ben Peart <benpeart@microsoft.com>
> ---
> convert.c | 46 ++++++++++++++++++++++++++++------------------
> 1 file changed, 28 insertions(+), 18 deletions(-)
> 
> diff --git a/convert.c b/convert.c
> index f569026511..747c0c363b 100644
> --- a/convert.c
> +++ b/convert.c
> @@ -576,14 +576,15 @@ static void stop_multi_file_filter(struct child_process *process)
> 	finish_command(process);
> }
> 
> -static int start_multi_file_filter_fn(struct cmd2process *entry)
> +static int start_multi_file_filter_fn(struct subprocess_entry *subprocess)
> {
> 	int err;
> +	struct cmd2process *entry = (struct cmd2process *)subprocess;

I wonder if a "subprocess_entry" should rather have a generic data pointer
for any extra information. However, this is probably bikeshedding and I think
this solution is equally good.


> 	struct string_list cap_list = STRING_LIST_INIT_NODUP;
> 	char *cap_buf;
> 	const char *cap_name;
> -	struct child_process *process = &entry->subprocess.process;
> -	const char *cmd = entry->subprocess.cmd;
> +	struct child_process *process = &subprocess->process;
> +	const char *cmd = subprocess->cmd;
> 
> 	sigchain_push(SIGPIPE, SIG_IGN);
> 
> @@ -638,17 +639,21 @@ static int start_multi_file_filter_fn(struct cmd2process *entry)
> 	return err;
> }

> ...

> static int apply_multi_file_filter(const char *path, const char *src, size_t len,
> @@ -692,9 +698,13 @@ static int apply_multi_file_filter(const char *path, const char *src, size_t len
> 	fflush(NULL);
> 
> 	if (!entry) {
> -		entry = start_multi_file_filter(cmd);
> -		if (!entry)
> +		entry = xmalloc(sizeof(*entry));
> +		entry->supported_capabilities = 0;

If we would use a generic data pointer then we could initialize
supported_capabilities in "start_multi_file_filter_fn".


Apart from the bike shedding above this patch looks good to me.
Minor nit: It breaks t0021 "invalid process filter must fail (and not hang!)"
test case but I assume this is corrected in a later patch.


Cheers,
Lars



  reply	other threads:[~2017-04-10 12:05 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-04-07 12:03 [PATCH v5 0/8] refactor the filter process code into a reusable module Ben Peart
2017-04-07 12:03 ` [PATCH v5 1/8] pkt-line: add packet_read_line_gently() Ben Peart
2017-04-09 19:34   ` Lars Schneider
2017-04-07 12:03 ` [PATCH v5 2/8] convert: move packet_write_list() into pkt-line as packet_writel() Ben Peart
2017-04-09 19:43   ` Lars Schneider
2017-04-07 12:03 ` [PATCH v5 3/8] convert: Split start_multi_file_filter into two separate functions Ben Peart
2017-04-09 19:56   ` Lars Schneider
2017-04-11 16:16   ` Jeff King
2017-04-11 19:29     ` Lars Schneider
2017-04-11 19:37       ` Jeff King
2017-04-11 20:01         ` Lars Schneider
2017-04-11 20:05           ` Jeff King
2017-04-20 17:27             ` Ben Peart
2017-04-07 12:03 ` [PATCH v5 4/8] convert: Separate generic structures and variables from the filter specific ones Ben Peart
2017-04-10 10:18   ` Lars Schneider
2017-04-17  3:31     ` Junio C Hamano
2017-04-18 16:38       ` Ben Peart
2017-04-19  1:23         ` Junio C Hamano
2017-04-20 17:24           ` Ben Peart
2017-04-07 12:03 ` [PATCH v5 5/8] convert: Update generic functions to only use generic data structures Ben Peart
2017-04-10 12:05   ` Lars Schneider [this message]
2017-04-07 12:03 ` [PATCH v5 6/8] convert: rename reusable sub-process functions Ben Peart
2017-04-10 12:11   ` Lars Schneider
2017-04-07 12:03 ` [PATCH v5 7/8] sub-process: move sub-process functions into separate files Ben Peart
2017-04-10 12:41   ` Lars Schneider
2017-04-07 12:03 ` [PATCH v5 8/8] convert: Update subprocess_read_status to not die on EOF Ben Peart
2017-04-10 12:48   ` Lars Schneider

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: http://vger.kernel.org/majordomo-info.html

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5900F7F1-89D9-433E-A6C3-0AB27C815BE6@gmail.com \
    --to=larsxschneider@gmail.com \
    --cc=benpeart@microsoft.com \
    --cc=christian.couder@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=peartben@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://80x24.org/mirrors/git.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).